SR Macbook: how to disable X3100 v-sync?

Discussion in 'MacBook' started by Cancelliere, Jun 15, 2008.

  1. Cancelliere macrumors newbie

    Joined:
    Sep 1, 2007
    Location:
    Parma - Italy
    #1
    Some months ago, I have found in this forum a tip that made animations (i.e Exposé-all windows) run smoother on my 2.2 GHz SR Macbook; this happened by disabling v-sync.

    How can I disable it again?
     
  2. ihabime macrumors 6502

    Joined:
    Jan 12, 2005
    #2
    There's a setting in Quartz debug to disable beam sync.
    If you have the developer tools installed Quartz Debug is in :

    HardDrive/Developer/Applications/Graphics Tools

    start it up, in the Tools menu there's an entry for Show Beam Sync Tools
    change the setting to Disable Beam Sync, but don't close the window. If you quit quartz debug normally it resets all the options, so you have to use Force Quit by holding down option and left clicking on its dock menu.

    I'm not sure how stable that setting is, some things in Quartz Debug can have unpredictable results.

    Hope that helps.
     
  3. pyr0sphere macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Toronto, Canada
    #3
    Since updating to 10.5.3, I haven't needed to do that anymore. Things are much better for me
     
  4. Gokhan macrumors 6502a

    Joined:
    Oct 7, 2003
    Location:
    London
    #4
    really ?

    since the update my animations freeze and i get graphical artifacts not good :confused:
     

Share This Page