SR MPR Crashes Civ 4

Discussion in 'Mac and PC Games' started by incoherent1, Jun 16, 2007.

  1. incoherent1 macrumors member

    Joined:
    Jun 5, 2007
    #1
    Hello,
    I have a stock SR 2.2 MBP and Civ 4 has been crashing like no one's business. It started to crash during game play, but I was able to finish with frequent saves. Now I'm trying to start a new game and it crashes every time before I can even get to the game. I've tried many different graphics settings and resolution level combinations, but no help.

    My hypothesis is that Civ 4 hasn't been patched for the 8600M yet. Does that sound logical? Civ 4 runs 100% stable on a friend's 1.83 C2D MB (albeit at low graphics settings).

    Many thanks.
    M

    Edit: Title should have been MBP, obviously
     
  2. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #2
    Yes, the most likely culprit is the graphics card. I'd email Aspyr and sit tight for a patch. You are up to date with the latest patch, right? The initial version of Civ IV was very unstable.
     
  3. incoherent1 thread starter macrumors member

    Joined:
    Jun 5, 2007
    #3
    Yep - I'm up to date on the patches. I've also tried everythig else I can think of (reinstalling, quitting all non-essential processes, etc.). In my many years of Mac, I've never seen anything this unstable, so I figure it must be drivers.

    This may be useful for the many threads asking about the SR MBP as a gaming platform. Wild guess I'd say other games would have similar problems - maybe not to this extent, but there nevertheless - until new patches are released.

    Thanks for your help. I'll shoot Aspyr an e-mail.
     
  4. Chone macrumors 65816

    Chone

    Joined:
    Aug 11, 2006
    #4
    I think your best bet right now would be installing Bootcamp and playing Civilization 4 under Windows.
     

Share This Page