SSD Boot Issue

Discussion in 'MacBook Pro' started by HarryTmac, May 13, 2016.

  1. HarryTmac macrumors newbie

    Joined:
    May 13, 2016
    #1
    I've got a mid-2012 unibody macbook pro 13".

    I replaced the original HDD with a samsung SSD and it worked perfectly running El Capitan for 3 months.

    However- now it doesn't boot and comes up with a gray screen with the prohibition or 'cancel/stop' sign.

    I have my old HDD which boots externally in an enclosure, but doesn't boot when I put it back in the laptop. The SSD doesn't boot internally or in the enclosure.

    I cannot repair the SSD with disk utility, as it cannot be fully verified.

    I tried to erase the SSD (which worked) but a clean install of El Capitan from a bootable USB drive failed and now the SSD boots with a folder and flashing 'question mark'.

    Any ideas what to do next? I would naturally assume it's the SATA cable- but the SSD is recognised internally (desktop icon) when I boot and log on from the HDD in the enclosure!
     
  2. squarebreathing macrumors member

    squarebreathing

    Joined:
    Feb 16, 2016
    Location:
    Baltimore
    #2
    I would also assume something happened to the SATA cable or something wrong with the logic board. It's probably out of Apple Care Warranty which sucks...I wouldn't give up on it, but I wouldn't put any money into it. Sorry I can't be more helpful here - anytime this happens it's either the hard drive or the connections to it and you ruled out a hard drive issue.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    It sounds like the internal SATA cable is bad and perhaps that corrupted the SSD. Can you put the SSD back in the external enclosure then boot to your USB installer and format the SSD and reinstall to it there. If that works, I'd say you have a bad internal cable.
     

Share This Page