SSD does not work only on primary drive slot

Discussion in 'MacBook Pro' started by slck, Jan 16, 2013.

  1. slck macrumors newbie

    Joined:
    Mar 22, 2011
    #1
    Hi all

    I have the following very strange problem with my 13" late-2011 MacBook Pro.

    The disk configuration is as follows:

    Primary slot - FileVault 2 encrypted 120GB OCZ Vertex 3 SSD
    Secondary slot - the original 500GB hard drive in a caddy

    For a year the computer worked flawlessly, until yesterday.
    When I got home from work, I opened the laptop and it was supposed to wake up. Instead, it showed only a one-color screen and wouldn't wake up. So I closed and opened the lid a couple of times (it worked before), hoping that it will wake up. When it didn't, I decided to power it down from the power button.
    Then, when I turned it on, it wouldn't boot at all.

    After the initial infarct thoughts of dead SSD, playing with all possible boot modes and stuff, in safe mode it showed that it is indefinitely waiting for a boot device.

    So I switched the drives, the SSD went in to the caddy and the HDD went into the primary slot, an VOILA - it worked again! The good thing was that the SSD is alive (the last Time Machine backup was 1 month old, which was bad).

    When I booted in restore mode I tried to unlock the encrypted SSD in order to repair it and its permissions, but could not. Did a search and found out that it should be because of problematic encryption.

    Then, I decrypted the SSD successfully from within OSX, and tried to switch the drives back to the original configuration - the SSD in the primary and the HDD in the secondary slot.

    To my big surprise, it does not work! There is some problem having the SSD in the primary slot.

    The laptop is out of warranty, I need it badly and I live in a country with very expensive services, so I am trying to find out the problem without leaving it in the repair shop for days or weeks.

    So any thoughts on what could the problem be? Thanks in advance!
     
  2. BlazednSleepy macrumors 6502a

    Joined:
    Apr 15, 2012
    #2
    Did you back everything up when you could finally boot into the OS?
    I would just completely reformat both drives and start fresh.
     
  3. slck thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #3
    But will a full restore from Time Capsule backup bring back the same partitioning / drive boot setup?
     
  4. slck thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #4
    So, I decided to try to encrypt my SSD which is the primary OSX drive installed in the secondary slot (instead of the optical drive).
    The FileVault 2 is stuck on Estimating Time Remaining... for 2 days now, so I guess it is not going anywhere.

    Any ideas?
     
  5. cookiesnfooty macrumors 6502

    cookiesnfooty

    Joined:
    Jul 1, 2009
    Location:
    Harrogate
    #5
    Oddly I have the same issue I am running my Macbook from the ODD bay at the moment and disconnected the SATA cable from primary slot. I have assumed it is a bad cable and intend to order a replacement.
     
  6. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #6
    FileVault 2 and SSD's do give problems now and then, so that might be the problem here too.
     
  7. slck thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #7
    I guess it's not a bad cable in my case, as the HDD runs just fine in the primary slot..
     
  8. slck thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #8
    Here is a screenshot of what I see:


    [​IMG]


    And here is what happens if I try to turn FileVault off:


    [​IMG]
     
  9. slck thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #9
    After a few restarts, the FileVault is again showing that it is disabled!
    Success, now I just have to manage to tackle the SSD-in-primary-slot problem, starting with a TimeMachine restore try..
     
  10. slck thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #10
    Ordered a new Intel 520 SSD and it is also not recognised.
    The problem seems to be the cable - ordered one from Hong Kong..
     
  11. slck thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #11

Share This Page