SSD fried? Flashing folder icon with question mark in it

Discussion in 'MacBook Pro' started by vaikak, Oct 27, 2014.

  1. vaikak, Oct 27, 2014
    Last edited: Nov 4, 2014

    vaikak macrumors newbie

    Joined:
    Oct 27, 2014
    #1
    Hey everyone,

    for the first time since I have owned my macbook Pro (mid 2010 13" currently running Mavericks) I´m having an issue I cant seem to resolve on my own. About 3 years ago I upgraded the internal 350gb HDD to a 128gb samsung 460 SSD. Up until now it has been running without a problem. When I got home today and opened up the laptop (it was asleep) it showed me the login screen and the dreaded spinning wheel. I left the laptop to do its thing for about 10 minutes. After 10 minutes of waiting I figured I would trz a hard reset. After the chime I got a folder with a blinking question mark in it. I did some googling and found out that it cant find the correct sytem software. Following a bunch of other forum tips I tried booting in OSX recovery and running Disk utility.
    Up until there everyything worked as planned (disk utility was able to see the drive). I couldnt however verify or repair the disk. I got both File check exit code is 6 and 8. Following that I got a message (paraphrasing) saying the OS (bootsector) cant be located and I need to reinstall the OS.

    The other thing I tried was telling the laptop which drive to boot off of.

    Currently I am instaling OSX Mountain Lion on a USB drive and trying to salvage what I can of my data.

    My Question(s) being:
    Is my SSD fried or did something just get corrupted when I did the hard reset?
    Is there any way to fix my issue without a fresh install? (I have a time machine back up...but on a drive I was dumb enough to lend my buddy...who lives 8 hours away)
    Is it even possible to salvage data off of my SSD by booting off of a USB drive (since both have an OS on them. One Mavericks and one Mountain Lion)

    If I have to do a fresh install it wouldnt be the end of the world. There are a few files I would like to keep, mainly pictures and all of my browser bookmarks.

    Sorry for any formatting issues. I´m currentlz posting this from my roommates old and tinz acer netbook, which for some reason also has a german keyboard.

    Thanks for any help in advance!


    EDIT: I was able to fix my issue. All I had to do was reset the NVRAM. (Command+option+p+r on start up)
     
  2. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #2
    The 2010's 13"'s have a known problem with the hard drive's ribbon cable being unreliable. So I'd bet my money on either that being the culprit or your SSD dying.

    Either way, a dead SSD should be readable, just not writable, so you should be able to pull data off of it if you succeed in getting it to mount in an external enclosure.
     

Share This Page