SSD Hard Drive. Restored from Leopard. Cant get to Sierra

Discussion in 'iMac' started by 228rory, Dec 11, 2016.

  1. 228rory macrumors newbie

    Joined:
    Jul 20, 2011
    Location:
    Denver
    #1
    OK.

    I just installed a new SSD hard drive into my imac24 (2008ish) and tried to restore and got stuck with the flashing ? folder. I was running Sierra on my old hard drive, and I guess my imac is too old to do a internet restore. I panicked and remembered that I had an old 10.5 leopard DVD, so I used that and formatted the new hard drive. Then I tried to restore from a time machine back up. No go because I am running an old OSX. So I used my MacBook Pro to create a USB bootable disc with Sierra, and tried that, but wont work because of "architecture". Please help. What should I do? Do I have to buy Snow Leopard to get back to where I was?
     
  2. infinity69 macrumors newbie

    Joined:
    Nov 23, 2016
  3. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #3
    Your iMac does not support Sierra, but you can install El Capitan if you make a bootable installer for it.
     
  4. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    It's a bit late now, you should clone your HDD to the SSD, and tested if it can boot (e.g. via USB port) before you swap it in.

    Now, you can still try to boot your Mac from your old HDD (externally), then clone it back to the new internal SSD (e.g. by Carbon Copy Cloner).
     

Share This Page