SSD+HHD: "Unable to log in the user account"

Discussion in 'MacBook Pro' started by tygold, Aug 11, 2010.

  1. tygold macrumors newbie

    Joined:
    Apr 17, 2010
    #1
    Hello,

    i have a small problem :)

    Some weeks ago i exchanged my DVD-Drive with an SSD. Using Carbon Cloner, i copied all necessary files, except the home-Directory to the SSD and everything worked fine (i followed the HowTo on "lifehacker").

    Today i wanted to exchange the old HDD against a new Scorpio blue. To do this, i hooked the old HDD (still bootable) and the new HDD (in the DVD-slot) in the MBP and used CC to copy the home directory. After that i exchanged the old HDD against the SSD and booted. Now, i get the message "Unable to log in to the user account [name] at this time".
    When i exchange the new HDD against the old one, i can log in without any problems, so i think, i might have missed some files to copy. But i have no clue whats wrong.

    I read in a thread that it might be due to wrong user permissions, but i repaired the new HDD and no error was found (could use "repair user permissions").

    Does anyone have an idea what could be wrong ?

    Thanks in advance,

    Tobias


    p.s. the next step would be to completely copy the old HDD on the new one and start deleting useless folders, but i wanted to have a nicer solution :)
     
  2. tygold thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #2
    Hmm,

    it just occurred to me, that the new HDD has a different name than the old one. Might that be the Problem ?

    But when i changed from the HDD to SSD it worked although OSX didn't find the home directory.


    Tobias

    P.S. i don't know if i am in the right subforum, i thought it might have occured to several people changing the MBPro from HDD to SSD and then to a bigger HDD - so how did you do it .... without making a new install.
     
  3. tygold thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #3
    Ok, i did some testing today.


    I made a new account with the home directory on the ssd and booted with the SSD+big HDD and i only saw the old account, the new account was nowhere to be seen (it works with the old HDD).
    I fear that i might have missed some crucial files to copy from the hdd to the ssd and now, whenever the "Macintosh HD" is missing, i can't boot properly.

    Could this be ? Is there a solution to my problem ?

    Tobias
     
  4. Argon21 macrumors member

    Joined:
    Jun 25, 2010
    Location:
    Алейск, RUSSIA
    #4
    Why did you not copy Home??? Very strange you did not copy home. USer cannot log in with a home!!!!
     
  5. tygold thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #5
    Hello,

    the idea is - and this works perfectly with the ssd - that the data (=home) is on the slow HDD and the system on the SSD, this saves space on the expensive SSD. Usually the home-directory doesn't need to be on the same drive, you just have to point to where the directory is.

    When i first booted with the SSD, a home-directory has been created on the SSD, which still exists - maybe this is the problem, as the system on the SSD doesn't find a home-directory when i boot with the new HDD and wants to create a new one, but there is already one, which might not be accessable (don't know why).

    Well, if there is no easy fix, i will just copy the whole old HDD (including home) on the new HDD, boot from the new one and use CC to copy the system-files on the reformated SSD. This should make sure that all my Data still exists. The only problem is, that this takes some time.
    So if there is a easier and faster way i would really want to know :)

    Tobias
     
  6. tygold thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #6
    Problem solved :)

    I think the Problem was, that during the first change from the SSD to HDD, a home directory was created on the SSD as the old home-directory wasn't there. At this time the path for the home directory was just "usr/name", so it could be easily created. Later i changed the path of the home-directory to the one on the old HDD ("macintosh hd/usr/name") and never used the home directory on the SSD.
    Then when i exchanged the HDD, the new HDD had to have a different name than "Macintosh HD", so when i booted with the SSD and new HDD, MacOS didn't know where to create the home directory and just gave a error.

    I could solve this problem by creating a new Admin-account with the home directory on the SSD and then change the name of the new HDD to "Macintosh HD". Now i can access the old account again and everything works fine :)

    Hope this helps if someone else runs into this error.

    Tobias


    p.s. in an earlier post i stated that when i create a user account it doesn't show up - well, i didn't check which drive i booted, so booted with the old HDD instead of the SSD by mistake.


    p.p.s. Yay to SSD and 500 GB of HDD :D
     

Share This Page