SSD in mid 2007 MacBook only reads @ 120MB/sec?

Discussion in 'MacBook' started by Novecento, Sep 23, 2011.

  1. Novecento macrumors member

    Joined:
    Jul 6, 2011
    #1
    Hey,

    so I got a OCZ Agility 2 for €60 and put it into my MacBook from mid 2007. The inbuilt SATA I controller is supposed to link at 1,5Gigabit/sec yet according to XBench the drives reads only 120MB/sec.
    The same drive does ~240MB / sec in my PC with SATA II controller.

    Why is it that the drive only does ~1GB/sec in my MacBook? Is 1,5GB/sec just the theoretical link speed that is never to be seen in reality?

    Thanks in advance,

    NVC0
     
  2. blackburn macrumors 6502a

    blackburn

    Joined:
    Feb 16, 2010
    Location:
    Where Judas lost it's boots.
    #2
    It's 1.5Gbit not gigabyte. So at most it would it 1500/8 = 187,5 Mbytes/s but that really never happens. There are other things that affect performance like NCQ that sata I doesn't have.
     
  3. Novecento thread starter macrumors member

    Joined:
    Jul 6, 2011
    #3
    Sorry, I mixed up the abbreviations. :)
    I meant 1 GBit/sec.

    So there's no way to get more than 120 MegaByte per second? (which is much faster than what I was used to from my old 7200rpm 500GB drive :) )
     
  4. blackburn macrumors 6502a

    blackburn

    Joined:
    Feb 16, 2010
    Location:
    Where Judas lost it's boots.
    #4
    I don't know if there is any tweak for it, but you got the most important thing that comes with ssds almost 0 access time and high IOPS. It will perform faster in a sata 2 envoriment but like my old laptop your stuck with sata 1 speeds, but it's way faster than the hd it replaced.
     

Share This Page