SSD in optical bay trouble - MacBook Pro Mid 2012

Discussion in 'MacBook Pro' started by 6825924, Aug 7, 2013.

  1. 6825924, Aug 7, 2013
    Last edited: Aug 7, 2013

    6825924 Suspended

    Joined:
    Aug 13, 2012
    #1
    Hi guys, here's a short summary of what is going:
    I bought a Samsung 840 SATA III 120 GB for my MacBook Pro 13" Mid 2012 and installed it in the optical bay. I have to tell that I bought an adapter for a SATA II SSD but people told me this would not affect the functionality of the disk.
    My MacBook is already running on OS X Mavericks, this might have caused some trouble but I'll explain that later.

    After erasing the SSD in Disk Utility it showed up as it should in the sidebar in the Finder app.
    So up next: cloning all files from the original Macintosh HDD to the SSD, which should be no problem because it contains like 70GB of files.
    So I downloaded the paid version of Superduper! After a few gigabytes being copied it shows me an error that some files can't be copied so I cannot proceed.
    Perhaps it's just the app? So let's try another one: Carbon Copy Cloner.
    After trying to open the lastest version (so Mountain Lion supported) a pop-up shows up that the OS X version is yet not supported. So I continue my search

    Enough of the third party apps, I concluded this job could only be done with the Startup Manager. I restart my computer and holt the option key ofcourse and run disk utility.
    Restoring the Macintosh HD onto the Samsung SSD seems impossible, not enough disk space on dev/disc02 (not really the name but I can't recall), error 254 and could not validate - input/output error.
    Okay, Disk Utility seems to be out of the question... So now let's try to restore a backup from my Time Capsule on the SSD! Again an error, restart your computer and try again.
    Last option! (that I know of ofcourse): Reinstall OS X, I sign in with my Apple ID and nothing happens. It says OS X will be installed on the disk, and that's it. When repressing (if that even is a word?) 'install' it just asks me to log in again...

    Your help would be very appreciated, I tried to speed my MacBook up with the little budget that I have + I voided my warranty by putting the SSD in :D
    I have very little time actually to figure all the options out how to solve this, I have retests in a week and a half (psychology student) and should be studying... Instead I'm here trying to figure put what's wrong because of a lack of discipline :eek:
    Thank you for your time and help you guys!



    God bless
     
  2. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #2
    Option boot to recovery partition and install OSX to SSD from there. Then setup assistant to migrate from HDD. Oops I see you tried that. Disregard.
     
  3. 6825924 thread starter Suspended

    Joined:
    Aug 13, 2012
    #3
    Actually, I didn't make a recovery partition, or are you talking about a back up?
     
  4. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
  5. eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #5
    The optibay is limited to SATA II. The general consensus on this forum is to move the SSD to the primary bay and the HDD to the optibay.
     
  6. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #6
    This applies to 2011 and earlier models. Later models came with SATA III.
     
  7. 6825924 thread starter Suspended

    Joined:
    Aug 13, 2012
    #7
    That's the same as holding down the alt key while booting?:) Already tried those utilities, thank you though
     
  8. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #8
  9. 6825924 thread starter Suspended

    Joined:
    Aug 13, 2012
    #9
    Hey, thanks for the input! I'm trying to update the firmware but since the described method (with cd or dvd) is impossible for me because the optical drive is replaced, I am looking for another method, I'm looking to 'burn' the .iso to a USB drive, but that seems even more impossible? Thanks for the help!
     
  10. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #10
    It is referring to EFI firmware update for the MBP. Download here:

    http://support.apple.com/kb/HT1237

    System Info, Hardware tab will verify which version is installed.
     
  11. 6825924 thread starter Suspended

    Joined:
    Aug 13, 2012
    #11
    I don't get it, the EFI firmware is up to date :eek:
    Thank you for your reply, I appreciate it!
     
  12. 6825924 thread starter Suspended

    Joined:
    Aug 13, 2012
    #12
    The problem is solved. Moved the SSD to the main bay, could have put the HDD in the optical bay but didn't feel too good about that because of the sudden motion sensor. So I reinserted the optical drive.
    In the future I will try to buy a bigger SSD, again for the main bay, because an SSD in the optical bay doesn't seem to be so perfect as described.

    Thanks for all the help!
     
  13. Xenophyte, Jan 5, 2014
    Last edited: Jan 5, 2014

    Xenophyte macrumors newbie

    Joined:
    Dec 11, 2011
    #13
    Same problem: Only 100MB/s Write, 300MB/s Read

    15" Mid 2012 Macbook Pro, 2.7ghz
    16GB RAM
    OSX Mavericks 10.9.1, all updates installed
    Primary SATA bay: Samsung 840 Pro SSD, 512GB
    Optical SATA bay: Samsung 840 Pro SSD, 512GB
    Optical SATA adapter: OWC Data Doubler

    Blackmagic Disk Speed Test, 5GB test size, Results:
    Primary SATA HDD bay: 400+ MB/s Write, 500+ MB/s Read
    Optical SATA bay: ~ 100MB/s Write, ~ 300MB/s Read

    I have tried swapping the SSDs and even using different SSDs so I know it is not a problem with the SSD itself.:confused:

    Now I am wondering if it is the Macbook itself or the OWC Adapter bracket. Is anyone getting full speed using an SSD in the optical bay in the 15" model of MacBook Pro Mid 2012?

    Optical SATA adapter buyers: Warning::mad:
    Do not buy the cheap $10-20 adapters found on Amazon and other places such as this one.

    These units have poor quality control! The cheap adapter caused me a lot of headaches trying to narrow down the cause of the errors I was getting - this caused "Error -36" which is a hardware error reported by OSX. The error occurs when copying files larger than 1GB or so. No file errors when using the OWC adapter, but still not getting full speed obviously.
     
  14. Mr Ghz macrumors newbie

    Joined:
    Jan 7, 2014
    #14
    I got it to work!

    HI!

    I think I found a SSD that works in the optical bay, and it is the Crucial M500 480 GB.

    My system:

    Mac model: MacBook Pro (15-inch, Mid 2012) (MacBookPro 9,1)
    OS: OSX Maverics 10.9.1
    CPU: 2,6 GHz Intel Core i7
    Memory: 16 Gb
    Main bay: Samsung SSD 840 PRO Series 256 GB
    Optical bay: Crucial M500 480 GB
    Optical bay caddy: 12£ on ebay, the one without a propper name:p

    Both drives runs at SATA 6Gb/s (tested in Blackmagic speed test), although I think it might be something fishy with my Samsung (slow when it comes to write (Write: 100 MB/s Read: 325 MB/s)

    I tried with the Samsung SSD 840 PRO Series 256 GB in the optical bay to no avail, and also the OCZ Agility 3 240 GB. None of these would mount, and therefore I couldn't format any of them. They worked perfectly well everywhere else, both on MAC and PC.

    So, if nothing else works for you, I recommend trying the Crucial M500 480 GB (The other sizes probably works as well, although I haven't tested them)
    I can't guarantee that it works for you, but I've had mine for about 3 weeks now and it runs like a charm!

    I work with music, so I have my Kontakt sample library on the Crucial, my Cubase an OS on the Samsung, and record to the project files on an external OCZ Agility 3.

    Whoop whoop!

    -Ghz
     
  15. wonderspark macrumors 68030

    wonderspark

    Joined:
    Feb 4, 2010
    Location:
    Oregon
    #15
    I have a 2012 2.3GHz 15" cMBP, 16GB RAM from Crucial, and dual SSDs w/ OWC Data Doubler bracket. The SSD in the main slot is Samsung 840 Pro 256GB, and the SSD in the Data Doubler bracket is a Samsung 840 EVO 1TB. They both run at max advertised speeds.
     

    Attached Files:

  16. imorton macrumors 6502

    Joined:
    Aug 21, 2010
    #16
    I'm having the same issue.... It all worked fine in my 2011 MB Pro (dual SSD's). Now that I have a 2012 13" MB Pro, keep getting Format or Partition errors etc....

    I actually swapped the OptiBay SSD for another SSD, and it also had errors, so it's not the SSD... :(

    Do you guys think that it could be a CHEAP optical bay caddy adapter causing the issue?
     
  17. imorton macrumors 6502

    Joined:
    Aug 21, 2010
    #17
    UPDATE: it turns out it was the cheap Optical Drive caddy that was causing the issue. I ordered a OWC Double Data Adapter and the issue disappeared and the speeds are SATA3 on both the main & optical bay. :)
     

Share This Page