SSD just won't work

Discussion in 'MacBook Pro' started by andothfc, Aug 13, 2009.

  1. andothfc macrumors regular

    Joined:
    Jul 11, 2008
    #1
    I recently bought the new Crucial 128GB SSD but have been wholly unable to get it to work in my MBP.

    I installed in as the internal drive, booted from the Leopard CD and it didn't recognise the drive. So I formatted the SSD as Mac OS Extended (Journaled) with GUID. It now saw the drive but the install process would then fail at various points. Sometimes it would freeze and fail to install, sometimes it would complete the install but then immediately 'lose' the drive so when it rebooted to complete the process it couldn't see the drive and would boot back into the CD. Holding option on boot at this point did not give me the option of booting from the SSD.

    I then tried booting from a Carbon Copy Cloner backup and copying that to the SSD. This process worked but when I booted from the SSD, my Mac would freeze up after a minute of two and force me to do a hard reset.

    Now you might dismiss this as a faulty drive but, for various reasons, I had ordered two of these drives (same drive, different suppliers) and both f them behave exactly the same way.

    Has anyone else experienced this or something similar. I must have tried installing and formatting and installing at least twenty times in the last day or so, checking through every possibility I can think of but to no avail.

    With my old HD in the computer is rock solid so there is no issue with the SATA cable etc.

    I have the mid-2009 15" MBP, 2.53 if that is relevant.
     
  2. sascha h-k macrumors 6502

    sascha h-k

    Joined:
    Apr 26, 2004
    Location:
    vienna / austria
    #2
    if you want a ssd that really works, buy any intel !

    try to return yours.
     
  3. MacModMachine macrumors 68020

    MacModMachine

    Joined:
    Apr 3, 2009
    Location:
    Canada
    #3
    the crucial ssd is crap, i bought a 256 gb one and returned it for the same reason, it does not work well.

    buy the intel 160gb ssd's, there very good
     
  4. andothfc thread starter macrumors regular

    Joined:
    Jul 11, 2008
    #4
    Well it's good to know it wasn't me doing something wrong.

    The crucial 128 was a bit of a sweet spot for me as I can't justify the price of the Intel 160 and the Intel 80 is just a bit too small.

    I guess I'll just hang on then until the next round of reductions.
     
  5. crisito macrumors regular

    Joined:
    Jun 11, 2009
    #5
  6. nws0291 macrumors 6502

    Joined:
    Apr 24, 2006
    #6
    If you are going SSD right now you should either buy Intel or OCZ. I would not waste your money elsewhere. They are the fastest and best priced of the drives that work perfectly. Intel should have their new version back on sale soon after the firmware fix.
     
  7. Salty Pirate macrumors 6502

    Salty Pirate

    Joined:
    Oct 5, 2005
    Location:
    kansas city
    #7
    could be the 1.7 firmware issue.

    I have the mid-2009 15" 2.53 and I tried to put my hitachi 320GB 7200 in it and when I booted off the DVD and ran disk utility, the drive could not be mounted or unmounted, so I could not partition it(it had existing data).

    I read the 1.7 firmware made the systems unable to recognize third party drives, so I wait for an update from apple and run the stock 250GB. I am gonna get one of the G2 Intel 160 GB SSDs when they start shipping again.

    Hope it works.....
     

Share This Page