SSD not being detected

Discussion in 'MacBook Pro' started by Mr MM, Jun 17, 2013.

  1. Mr MM macrumors 65816

    Mr MM

    Joined:
    Jun 29, 2011
    #1
    Howdy, I just received back my SSD, and guess what? it aint being detected at all by my mbp

    I did the basic things:

    1) format the SSD inside OSX, to check if it was working, strangely it gave me a warning that it wasnt at all

    2) formated anyway and checked the health of the HDD, it reported fine

    those steps were conducted using a USB caddy that I have

    3) put the SSD in the bay and proceed to install OSX, no dice, it isnt detected, even using terminal

    4) removed the ssd and put in the usb enclosure and tried to hook to my windows machine, no dice, had to reformat again to be visible

    5) put back again in the mbp, not detected again

    My guess is that its something that is broken in it, its a corsair F120 using the SF 1200 controller

    I will try to do some verification as to the condition of the SSD using chkdisk, since its fruitless to use disk utility

    any advice on options or apps that I should use?

    PS: its a mbp 13, early 2011, code 8.1
     
  2. ValSalva macrumors 68040

    ValSalva

    Joined:
    Jun 26, 2009
    Location:
    Burpelson AFB
    #2
    I had similar problems with an OWC Mercury Pro 6G SSD. I'd install it and then sometimes it would be recognized and sometimes not. I was even able to install OS X on it one day and then when booting up the next day the drive was not recognized. It was very frustrating as I'm sure you must be experiencing :mad:

    In my case it was an issue with the EFI firmware for the then new SATA-III interface and the firmware in the SSD. Updating both the firmware in the MBP and the SSD helped. I had to send the SSD back to OWC to have them flash it though. I just could not get their utility to work.
     
  3. Mr MM, Jun 17, 2013
    Last edited: Jun 17, 2013

    Mr MM thread starter macrumors 65816

    Mr MM

    Joined:
    Jun 29, 2011
    #3
    its supposed to have the latest firmware, since I had just received it from a RMA.

    My current guess is something related to how SF can get locked, however it doesnt fit on that assumption, because nothing I did can grant that lock.

    in the end im clueless, I will check the firmware though. I hope I dont have to send it for another RMA, since I just received this drive on friday, btw that would be the 4th RMA of this POS

    UPDATE:

    Im still clueless, there is indeed a firmware for the force series, the 2.4, however there are some force series, and mine is the 1st one, since its back from the rma with the 2.0, I will keep it at that.

    I did a CHKDSK and its fine, crystal disk info and disk utility still report the same, I keep being able to connect via USB, and not via sata on the mbp, I did manage to install ubuntu in another machine that I have here

    the problem lies on the compatibility of the mbp and the SSD. Which is bollocks, since that SSD was in this same mbp since 2011, and its past RMA siblings worked fine (till they died off course) with it. No compatibility issues at all.

    And yes the last RMAed SSD, before this one, came with the 2.0 firmware
     
  4. ValSalva macrumors 68040

    ValSalva

    Joined:
    Jun 26, 2009
    Location:
    Burpelson AFB
    #4
    Even though it's just been RMA'd it might not have the newest firmware. That was my experience at least. 3 RMA's already? That's rough :eek: Good luck with getting it working.
     
  5. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #5
    The 2011 MBP's have known issues with sata III ssd's in the optibay. If you have installed it in the optibay, try it in the main bay. If you have installed it the main bay and are having these issues, perhaps it is a problem with the sata cable.
     
  6. Mr MM, Jun 17, 2013
    Last edited: Jun 17, 2013

    Mr MM thread starter macrumors 65816

    Mr MM

    Joined:
    Jun 29, 2011
    #6
    its SF1200 so sata 2, and its in the HDD bay

    yeah, SF1200 is a pretty POS controller, not that SF2281 is any different

    I did get it to work, somewhat, in a very strange and absurd way

    1) bought a pack of ciggies, luckies to be precise
    2) put it into another windows notebook that I have
    3) cursed the skies because I couldnt find my windows thumb drive installer, used ubuntu instead
    4) installed ubuntu 13.04, cursed zoroaster since it installed
    5) put the SSD in the mbp, tried to install OSX, no dice, not detected
    6) holded option and actually was intrigued that a windows install was there, booted just to my surprise to see an almost fully functional ubuntu install (the usual issues with mbp)
    7) cursed heavens in futility

    Now what I just did:

    1) create 3 partitions on the SSD, OSX and ubuntu
    2) go to the windows notebook and delete 1 partition so that I can have some unallocated space
    3) install OSX in target disk mode (currently thats what im doing)
    4) shove it inside and see if it works
    5) curse athena because it didnt work again

    I will try to install ubuntu directly on that machine to see if it works

    Its installed and working fine, the grub allows me to boot into OSX, just that it doesnt boot at all. I will try latter to see if I can install OSX again on that freaking SSD


    its something related to OSX that doesnt suddenly like my SSD at all
     

Share This Page