SSD not recognized, unable to install

Discussion in 'MacBook Pro' started by sh3p, Nov 13, 2010.

  1. sh3p macrumors newbie

    Joined:
    Nov 13, 2010
    #1
    Hello all,

    Firstly thanks to all the members here, I have learnt a lot from your collective knowledge, and wonder if anyone can help me with this problem.

    I have a MBP mid 2009 ( 3.06 Ghz - 8GB Ram)

    Through work I managed to obtain a Lenovo 256GB ( Toshiba ) SSD.

    When i replace the current 500GB drive with the SSD and boot with
    the snow leopard (10.6.3) disc, the drive is not recognized.

    I go into disk utility and the only drive is the DVD drive.

    I put the SSD in a pc laptop and booted with a Ubuntu Usb drive and it found the SSD first go..no issue..so the drive works...

    Any ideas?

    info on drive sticker is

    Lenovo PN: 45N8206
    Lenovo FRU : 45N8207
    SOLID STATE DRIVE
    THNS256GG8BAAA
     
  2. phpmaven macrumors 68040

    phpmaven

    Joined:
    Jun 12, 2009
    Location:
    San Clemente, CA USA
    #2
    I would try getting yourself a USB to SATA adapter (cheap at Fry's) and use CarbonCopy to clone the drive from the current one and then swap the drives and see if it sees it then.
     
  3. sh3p thread starter macrumors newbie

    Joined:
    Nov 13, 2010
    #3
    Good point, though i pulled apart a USB drive, and connected the ssd via USB to the laptop...didnt see it, or do anything...though it was a bit of a DIY makeshift job....

    Could it be some kind of firmware needed by the MAC?
     
  4. sh3p thread starter macrumors newbie

    Joined:
    Nov 13, 2010
    #4
    This is driving me nuts!

    Formatted in in ubuntu, still not showing up in disk utility off the Snow Leopard DVD....

    Any one? please!!! :confused:
     
  5. SomeOtherGuy macrumors newbie

    Joined:
    Mar 14, 2008
    #5
    Do you have the EFI 1.7 firmware update? It's possible that that is what keeps the drive from being recognized.
    You can try to go back to EFI 1.6 (http://forums.macrumors.com/showpost.php?p=8416559&postcount=323) and try again - however, you're doing this at your own risk - I can't guarantee it will work.

    I haven't tried it myself, but you can read through the link I posted above and judge for yourself.

    Kindest regards,
    SomeOtherGuy
     
  6. sh3p thread starter macrumors newbie

    Joined:
    Nov 13, 2010
    #6
    still no luck

    Thought id have another go at this... anybody else have any other suggestions?
     
  7. NickZac macrumors 68000

    NickZac

    Joined:
    Dec 11, 2010
    #7
  8. BigMoo macrumors member

    Joined:
    Dec 12, 2010
    #8
    Here were the steps i took.

    1. Plug in external hard drive.

    2. Make one of my partitions a mac bootable drive and use carbon copy cloner to copy my hard drive in the MBP to the external hard drive. (I had already had my external hard drive into 2 partitions.)

    3. Take out old hard drive and put in new SSD.

    4. Turn on computer and hold option to choose what to boot from, i chose my external hard drive.

    5. Open up disk utility and format the SSD to Mac OSX Extended Journaled or whatever the name is.

    6. Use carbon copy cloner to copy the bootable drive from my external hard drive to my SSD.


    I don't know if you have tried this already or if anyone has told you to do so. But this was the way that i found easiest, and what worked for me.

    Hope everything works out for you!
     
  9. sh3p thread starter macrumors newbie

    Joined:
    Nov 13, 2010
    #9
    Thanks for the new tips!

    Thanks to the above for the recent tips...

    but still no luck... The HDD when connected via the external dock will not even show up on disk utility.... im starting to think its the SSD to SATA connection but cannot locate where Id get another one?
     
  10. sydenham, Feb 2, 2011
    Last edited: Feb 2, 2011

    sydenham macrumors regular

    Joined:
    Dec 23, 2010
    #10
    What do you mean by an external Dock? If the drive didn't work in an external USB case I would guess it is something to do with the drive.
    You were also told what to do with the firmware, however you chose not to.
     
  11. Quiz18 macrumors newbie

    Joined:
    Nov 15, 2012
    #11

Share This Page