SSD not recognized, won't boot

Discussion in 'MacBook Pro' started by kris-hm, Jul 4, 2015.

  1. kris-hm macrumors member

    Joined:
    Mar 25, 2014
    #1
    I bought an sad for my macbook pro, a 120gb crucial, my macbook pro is a mid 2012 model, 13".
    I cloned my hard drive to the ssd thinking that would be the best solution, but it did not work. when i tried booting from the ssd i just get the folder icon with the question mark on it.
    At that point i tried to format the ssd from disk utility via a mavericks disk i made. the ssd does not show up in disk utility at all.
    Then i tried with a usb adapter. It booted from the usb adapter. Then i booted to my mavericks disk after restarting and it showed up in disk utility as a usb external drive.
    I formatted it anyway and installed a fresh copy of OS X. Then it booted via usb again. Then i returned the ssd to the internal enclosure and it still would not boot the drive.
    So my next thought was the cable, in order to test this, i put the ssd in my other macbook pro, same model and everything with different hardware, by that i mean from an i5 to an i7 and ram difference.
    The ssd booted first try.
    In order to confirm that the cable was the culprit, i put the hard drive i originally took out back in...
    and it booted it perfectly.
    What is going on??? Im really starting to get aggravated.

    Please read this entire post, not just the title and start answering because I've already tried what most forums asked me to do and that is listed above.

    I don't know whats going on here. Why would the ssd work on one macbook and not the other? and even that, it works on an earlier model. the one it works in is an early 2011 model and it refuses to work in my mid 2012 model.
     
  2. kris-hm thread starter macrumors member

    Joined:
    Mar 25, 2014
    #2
    Update: i just reset the pram and the smc, still won't boot the ssd.
     
  3. kris-hm thread starter macrumors member

    Joined:
    Mar 25, 2014
    #3
    Nevermind, i took a hdd cable from another macbook and put it in the one I've been working on. it worked. the cable was the issue after all.
     

Share This Page