SSD Problems?

Discussion in 'MacBook Pro' started by David2144, Jul 10, 2014.

  1. David2144 macrumors member

    Joined:
    Jul 17, 2008
    #1
    OCZ Vertex 2 120gb installed in a mid-2010 Macbook pro. The speed tests are surprising now. it's been in use since 2011. Is there something wrong with this ssd? Yosemite is laggy and I'm wondering if the SSD has anything to do with it.

    Would replacing it with an 840 evo be a good idea at this point?
     

    Attached Files:

  2. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #2
    Have you tried running trim enabler??

    This will refresh your ssd and should get yours speeds up if you haven't used it already.

    3 years with no trim will do this to your SSD.

    You can download here, the basic version is free.

    http://www.cindori.org/software/trimenabler/
     
  3. Matt3o12 macrumors newbie

    Joined:
    Dec 12, 2013
    #3
    You're using Yosemite? Be careful with trim since it may destroy Yosemite (in Yosemite, you aren't able to modify kernel extension, which Trim Enabler does. You can find more information, and how to fix it, here.
     
  4. MagicBoy macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #4
    It's a Sandforce controller drive. OP is best doing a secure erase via the toolbox then restoring from backup to get back the original performance.

    Samsung and Marvell controller based SSDs (e.g. Crucial) offer better long term reliability and performance for OS X.

    An 840 Evo would be a good option.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    See if you can get TRIM enabled even if only temporarily. Then boot to single user mode and from the command prompt enter "fsck -fy" (without the quotes) and that will TRIM all unused blocks on the drive and hopefully restore performance. Then type reboot to restart.
     
  6. David2144 thread starter macrumors member

    Joined:
    Jul 17, 2008
    #6
    Secure Erase

    I've done a secure erase and a restore from clonezilla but the issue persists. Really don't know what's wrong at this point.
     
  7. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #7
    That should have fixed it. SSD might be dying, or since you are using 10.10, could be a driver problem of the beta.
     
  8. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #8
    Did you enable TRIM?
     
  9. alex0002 macrumors 6502

    Joined:
    Jun 19, 2013
    Location:
    New Zealand
    #9
    The SSD could be the problem... I thought all the OCZ Vertex 2 had been RMA'd already. :)

    One other problem could be the SATA cable.

    If you had a newer MacBook Pro with USB3, I'd suggest you take the SSD out of the Mac and put it in a USB enclosure and see if it's any faster, in which case I'd think it was a SATA cable or some other problem internal to the Mac. However, I'm not sure that method would be useful with USB2, as the SSD would probably still be slow due to USB2, even if the SSD was good.

    I'm running TRIM on my Crucial M500, but if you have just done a secure erase, then I don't think TRIM will make much difference in the short term. The main benefit of TRIM is in long term performance and some people will tell you not to use TRIM with those Sandforce controllers anyway.
     

Share This Page