SSD R/W Slow Down

Discussion in 'iMac' started by starscript, May 4, 2013.

  1. starscript macrumors member

    Joined:
    Dec 21, 2012
    Location:
    Glasgow, Scotland
    #1
    Hey Every One,

    I got my new iMac 2012 in December and put in a Samsung 830 256Gb SSD in it very soon after getting it.

    Recently I have noticed that things have been slowing down. So I ran Blackmagic speed test and I have decreased from just under 500Mbs transfer rate to around 200Mbs.

    I have Enabled Trim Support etc.

    Can any one explain whats happened to my transfer rate and how i can get it back?

    Thanks
     

    Attached Files:

  2. Nuke61 macrumors 6502

    Joined:
    Jan 18, 2013
    Location:
    Columbia, SC
    #2
    How full is your drive? Verify again that TRIM is enabled, set sleep to never, and let it sit idle overnight.
     
  3. starscript thread starter macrumors member

    Joined:
    Dec 21, 2012
    Location:
    Glasgow, Scotland
    #3
    Thanks, I did go and investigate Trim support.
    Turns out it got turned off,
    I suspect this happened when I took my iMac to get a repair.


    I tured Trim on, restarted poped to the shops back up to 500Mbs :)

    Thanks for your response
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    It usually gets turned off with each OS X point update because the tweaked kext files are overwritten, so it probably got turned off when you updated to 10.8.3.
     

Share This Page