SSD Samsung 840 Pro not detected internal, but works external

Discussion in 'MacBook Pro' started by Truster92, Mar 14, 2013.

  1. Truster92 macrumors newbie

    Joined:
    Mar 14, 2013
    #1
    Heya,

    I just received my new SSD 840 Pro which I tried to install on my Macbook Pro 2012 13". I can't detect the SSD at all when I have it connected, but if I use a enclosure and connect through USB it works fine. I've used this with Samsung 830 ( which died and I got this as a replacement ). I installed OS X on it through external and tried formatting it as GUID - Partiton table ( not sure if that's the correct way it's named ) installed OS X ML on it fine with when I formatted it as Mac OS Extended Journaled. The disc is completely fine. Tried connecting it to my brother's Macbook Pro 2010 and worked completely fine.

    I'm guessing it could be due to the HDD cable but wondering if anyone have run into same issue and fixed it. Considering the cable works fine with other HDD's etc and no damage on it at all so little skeptical that the cable is damaged.

    I've the latest firmware on the SSD and I had all the updates on the OS X when I tried to connect it to my Macbook.

    Thanks for reading and hope someone can help me :)
     
  2. pillecastro macrumors newbie

    Joined:
    May 28, 2013
    #2
    Excactly the same for me

    Hi! I have excactly the same problem, though mine is a mid 2009 macbook pro. Did you manage to find any solution?
     
  3. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #3
    It's highly likely that it's the cable. They're relatively dirt cheap. I got a couple for a total of around $25 after shipping a couple years ago, before I added an SSD to my early-2008 MBP.

    Good thing I did too, because they are extremely fragile little suckers, and had to use one of the replacements I bought.
     

Share This Page