SSD SATA III makes MBP 8,1 ULTRA SLOW

Discussion in 'MacBook Pro' started by brusMX, Nov 12, 2012.

  1. brusMX macrumors newbie

    Joined:
    Nov 12, 2012
    Location:
    mex
    #1
    I have a MacBook Pro 13'' (Early 2011)
    2.7 Ghz i7, 12 GB ddr3, OSX 10.8.2 (12C60)

    My HDD died and I decided to replaced it with a brand new SSD SATA III.
    I bought the ADATA SX900 256 GB and installed it.
    I made an USB key with Mountain Lion to proceed with the installation.
    For my surprise, the installation lasted more than 3 hours, when it was supposed to be no longer than 20 minutes. I thought that my internet connection could have something to do with that (but it actually didn't)
    After 3 clean installs, I have realized there was something wrong with the computer.:mad:
    My computer "works" but it couldn't be any slower. It took it more than 10 mins to start, and it takes it more than 1 minute to respond to any click or action I want it to do.

    I ran all the tests possible to determine the problem. But as you think, AHT didn't find anything. Also Disk utility said everything was perfect.
    Then I ran a benchmark test on the new drive, and I saw that it was about 350 mb/s on writing and 500 on reading.
    The disk was flawless, I double checked I had the EFI last upgrade.
    I even installed the TRIM Enabler, which worked correctly.
    I usually don't write in forums, but this is the first time I cannot solve the problem, and there is no info about something like this.
    I hope anyone here has some previous experience on this matter.

    Just so you know, I have replaced the disk and used a hdd from another computer and it works like a charm.
    I also realized that if i put the SSD in a USB SATA case, the computer also works fine.
    I believe, there has to be a problem with the memory or the processor when the SATA III is active, something that it makes the computer works so hard to access it that it takes forever to actually do something.
    So the SSD is fine, the computer has no trouble in using from a USB case. But if i use the SATA 3, it saturates the computer (memory??) (Processor)
    Please help me out here, I don't want to throw away this SSD and get a new HDD.
     
  2. Orlandoech macrumors 68040

    Orlandoech

    Joined:
    Jun 2, 2011
    Location:
    Salt Lake City, UT
    #2
    Which HDD bay did you put the SSD in? I assume the main bay?

    Also, why the ADATA SSD? Ive heard of ADATA but I'd never buy an SSD other than;

    Samsung
    Corsair
    Crucial
    OCZ

    And maybe a few select others.
     
  3. brusMX thread starter macrumors newbie

    Joined:
    Nov 12, 2012
    Location:
    mex
    #3
    Yes, you assume correctly, the main bay.
    I don't really think the problem could be the brand of the SSD. But if I can get another SSD from any of those brands i would try to replicate the problem. Perhaps, there could be something related to the SATA driver.
    And I chose that brand, because it was the one that my provider had when I needed it.
     
  4. brusMX thread starter macrumors newbie

    Joined:
    Nov 12, 2012
    Location:
    mex
    #4
    Another Funny Detail

    So I decided to take my chances and change the hard drive on my iMac 27'' Late 2009 i7.
    Funny story, it works great.
    I mean it's not SATA III, but it does the trick. The iMac is going super fast and the benchmark is around 250 mb/s. (read/write) It might not be 500 that I wanted to. But it's definitely working.

    This new event, tells me two things:
    First, MacBook Pro 13'' (Early 2011) either has a software (EFI related) problem with SSD, or a Hardware problem like many object. Maybe it is an Apple's trick to prevent most users to get SSD from different providers. Or it's just a bug, that just appears under certain conditions on the macbook pros.
    In any case, make sure you get a SATA II SSD, and read the SSD Buying guide http://forums.macrumors.com/showthread.php?t=1177020

    If anyone else has this problem, make sure you do the EFI last upgrade check, also to enable trim. And make sure your MBP has SATA 3, and that is 6gb/s.
    I hope that in the future, Apple will release a real patch for 3rd party SSD SATA III to work with their computers. (keep dreaming)
     
  5. T5BRICK macrumors G3

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #5
    Um, there are plenty of people running SATA III SSDs in their early 2011 MBPs. I don't think it's a problem specific to the models. More likely it's an issue with your computer. Possibly your SATA cable is bad.
     
  6. brusMX thread starter macrumors newbie

    Joined:
    Nov 12, 2012
    Location:
    mex
    #6
    Probably, but is there a way to test it?

    It does sounds like a good explanation. But how could I test that, how can I know what is making my Computer to freeze and display continuous Mac Spinning Wheel.
    I'll try to get another cable this week and replace it. But I would have to say, that I don't really think that would be it.
    Maybe it is, a problem just with this SSD brand.
    Does anyone here with a MBP8,1 have been able to install an ADATA SX900 SSD?

    Cheers, and thanks for the advice.
     

Share This Page