SSD won't work on Aluminum MacBook...Please Help!

Discussion in 'MacBook' started by abs9986, Jul 19, 2012.

  1. abs9986 macrumors member

    Joined:
    Feb 23, 2009
    #1
    I just purchased the 128gb crucial m4 SSD to use in my late 2008 macbook alum. It also came with the transfer kit (usb to 2.5 SATA adapter) so I could clone my existing HD directly to the new SSD.

    I plugged in the SATA adapter and get a message "the disk you inserted was not readable by this computer"

    I click the initialize button which takes me to the about mac storage section where I do see the 128gb SSD being there (labeled Apricorn SATA Wire Media).

    When I launch the included cloning software (Super Duper) or when I try Carbon Clone Copy - the programs do not detect the attached SSD as the destination to make the clone from my HD.

    It must be because of the initial error message where the disk was not readable.

    Has anyone had this problem before? What should I do.

    Thanks,
     
  2. abs9986 thread starter macrumors member

    Joined:
    Feb 23, 2009
    #2
    Nevermind - I think I figured it out. Under the disc utility I did a hard reset on the SSD and now my mac recognizes it. Not sure why I had to reformat the SSD since it was brand new and didn't have anything on it.
     
  3. achillies39 macrumors newbie

    Joined:
    Apr 6, 2008
    Location:
    Waiheke Island, New Zealand
    #3
    MBP Late 2008 / Crucial M4 SSD problems

    I have just tried to install a 512GB in a late 2008 MBP and had a similar issue as abs9986. Had to re-format and then was able to clone my HDD to it and boot up and run OK while connected to USB2 using the SATA WIRE connection kit. When I then fit the SSD to the HDD bay I have endless problems.
    1. Initially the PB would not wake from sleep. Seemed to overcome that by un-checking "Put the hard disk to sleep when possible".
    2. Still had problems waiting for the spinning BB to wake Mac. Then got a kernel problem and had to reformat as Disk Utilty said it couldn't repair the drive. It mounted but couldn't boot from it.
    3. Crucial then suggested I install firmware v. 0309 which I did, re-formatted and then backed up again. Same problem, when I install in the HD drive bay I'm getting the Mac equivalent of the BSOD and the Catalogue hierarchy is completely corrupted.
    I've now repeated the process and have run for 2 days using the SATA WIRE/USB connection with no problems.
    This obviously isn't a satisfactory solution and I presume I'll have to return the unit to Crucial.
     
  4. jug97 macrumors newbie

    Joined:
    Oct 1, 2012
    #4
    Achillies39 ....I am having the exact same problem .... Late 2011 Macbook Pro 13in, Crucial M4 512GB SSD.

    Have cloned my hard drive with Carbon Copy, and with Super Duper, both resulting in the same. I can boot up with the SSD connected to USB. If I move the SSD into the hard drive bay, it will not boot up. Moving it back out to the USB will boot it up again.

    Did you ever figure out how to resolve your issue?
     
  5. achillies39 macrumors newbie

    Joined:
    Apr 6, 2008
    Location:
    Waiheke Island, New Zealand
    #5
    MBP Late 2008 / Crucial M4 SSD problems

    Hi jug97, been a long story - Crucial exchanged the M4 but still I still had issues with the new unit, see below.

    "Loaded up the new SSD(512GB-000F) from my backup and decided to boot up from it while still running on USB but couldn't select it as the start-up disk. "Building boot caches on boot helper failed", but I could boot off it using the "hold option key" and selecting it at start up.

    I then installed it in the MBP and it booted up after about 4 1/2 mins with a ? and stop sign showing briefly during bootup.
    Now have a series of Beach Balls and an unresponsive finder particularly if Time M/c running or other intensive operations but no consistency or pattern. Then re-installed OSX 10.8 with no improvement.
    Ran disk verify, "Disc appears to be OK". Ran repair permissions with this result - "Warning: SUID file "System Library /Core Services/Remote Management/ARD Agent app/Contents/MacOS/ARD Agent" has been modified and will not be replaced". Erased and re-formatted the SSD and went through the whole process with the same result".

    I used the M4 off the USB2 bus for some weeks using the option key at startup and then decided one day to re-install in the drive bay with the intention of erasing & re-formatting and starting over. However, when I put it back in the MBP and hit the start button it booted up normally and is now selectable as the startup drive. I am not aware of what may have cured it's problems so the story is not much help for you I'm afraid.
     

Share This Page