SSH and root access

Discussion in 'Jailbreaks and iOS Hacks' started by happyrock, Feb 21, 2011.

  1. happyrock macrumors newbie

    Joined:
    Feb 21, 2011
    #1
    Hey guys, I'm having a problem with getting root access to my VZ iphone. I can't for the life of me figure it out. Been searching the internet trying to find an answer and always come up short.

    Everytime I try I get connection refused
    I think I have everything I need. Openssh is installed on the jailbroken iphone. I have cyberduck and fugu installed on my mac. Is there anything else software wise I'd need? I've tried it with two different ip's at different homes, I've had the ssh icon turned on in SBsettings, tried root and alpine for username and password. tried different ports. Tried with Terminal but, nothing seems to work. I can't for the life of me figure it out. I want to say there is something else I have to enable on either the mac or the iphone before it will let me get root access

    Hopefully you guys can help figure this out, because I've no idea what to do.
     
  2. drummingcraig macrumors 6502a

    drummingcraig

    Joined:
    Sep 19, 2007
    Location:
    "Armpit of the South"
    #2
    The only thing that I can think of (which also tripped me up when I first tried the SSH connection) is to make sure you're pointing to the correct IP address. I was trying to connect to the "data IP address" until I realized I needed the "Wifi IP address".

    Other then that I have no clue, but I am sure someone else will come along with an answer for you.
     
  3. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #3
    If you have SBSettings installed, you have to connect to port 22 of the iPhone's WiFi address that is displayed on the dropdown. Also, make sure SSH is actually turned on via the toggle.
     
  4. happyrock thread starter macrumors newbie

    Joined:
    Feb 21, 2011
    #4
    Yeah I've only been using the wifi address
    Did all that. The toggle is on and everything.

    [​IMG]
    [​IMG]
     
  5. digitard macrumors 6502a

    digitard

    Joined:
    Sep 15, 2004
    Location:
    Gilbert, AZ
    #5
    No rudeness intended by the "duh" nature of this but... I'm assuming your phone is NOT in sleep mode when you're trying to SSH into it via CD, and your WiFi is currently on?

    #2 is probably a "of course", but I got so used to disabling mine when I wasn't using it over just a few days I ended up once getting raged at why it wouldn't connect and then realized I disabled it when I picked up my phone and ran to the store in between sessions.
     
  6. fuzion11 macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
    #6
    I know it might sound odd, but a year or two ago when I couldn't log into SSH I tried leaving out a digit or two from the IP address. For example if the address on your iphone under SBSettings says 192.168.1.102...I would try leaving out the last 2 digits "02"

    Last week I had a heck of a time trying to log into SSH at work and at home. I rejailbroke my phone and installed openSSH again and everything worked fine after that. As as last resort I'd say restore again and see what happens.

    Let us know if you get it working! Hope this helps.
     
  7. h1r0ll3r macrumors 68040

    h1r0ll3r

    Joined:
    Dec 28, 2009
    Location:
    Maryland
    #7
    This tripped me up for the longest time when I first started...durr hurr :confused: Never hurts to ask but gotta ask you know?
     
  8. happyrock thread starter macrumors newbie

    Joined:
    Feb 21, 2011
    #8
    hey dude, its wango from pbn, I posed the same question there but no one there could help me out either.

    Phone isn't in sleep. When i'm fiddling around with it, I turn auto lock off. I'm gonna try it again at my school, which has a different ip address, but I figure if I've already tried it on two different ones, thats not really the problem. This is really starting to get annoying.
     
  9. neko girl macrumors 6502a

    neko girl

    Joined:
    Jan 20, 2011
    #9
    @happyrock, how are you verifying the wifi address of your iPhone? How do you know you're SSHing into the right IP?
     
  10. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #10
    Your iPhone and the computer you are trying to connect with ARE on the same network aren't they?
     
  11. happyrock thread starter macrumors newbie

    Joined:
    Feb 21, 2011
    #11
    I checked both under settings, and it says the ip address in SBsettings. Both are the same
    both times I tried, they were on the same network


    I'm trying them on my schools wifi and I'm getting somewhere I think. It doesn't connect, but it doesnt say connection refused. It tries to open it with cyberduck, but then says connection failed and my ip address.
     
  12. lorax3, Feb 22, 2011
    Last edited: Feb 22, 2011

    lorax3 macrumors regular

    lorax3

    Joined:
    Jun 25, 2007
    #12
    Edit: Just saw you are on a school wifi. Try it on a personal network and see if it works.

    I would remove and install openshh again. I would assume there are no ssh issues with the verizon iPhone.

    Make sure the iPhone is on the same WiFi network as your mac. Are you using little snitch and accidentally denied CyberDuck any network access?

    Try in terminal just to see if you can establish a connection.

    Open terminal

    ssh root@192.168.2.1 (or whatever your IP is)

    it might ask you to type "yes" due to unknown key.
    Does that work?
     
  13. Ajones330 macrumors 6502a

    Ajones330

    Joined:
    Jul 9, 2008
    Location:
    SEC Country
    #13
    Try using diskaid, it works well for me... I use an att iPhone 4...
     
  14. happyrock thread starter macrumors newbie

    Joined:
    Feb 21, 2011
    #14
    there is nothing in preferences that would say that CD isn't getting network access, but I'm not sure what little snitch is. I've already tried it on two home networks already (mine and my sisters). Uninstalled and reinstalled openssh multiple times as well. Now I just get connection timed out on all 3, CD, Fugu, and Terminal.

    I'll try it
     

Share This Page