ssh broken after upgrade to 10.4.7

Discussion in 'Mac Programming' started by macbook123, Jun 30, 2006.

  1. macbook123 macrumors 68000

    Feb 11, 2006
    since I upgraded to 10.4.7, whenever using ssh I get a Segmentation Fault message. I also upgraded to the newest Xcode a few days earlier so it could be related to that. Any ideas what could be going wrong? Thanks.
  2. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    Did you use fink or darwinports to compile an Openssh other than the one the Mac is using?

    Make sure by specifying the COMPLETE path to darwin's ssh..

    /usr/bin/ssh user@host

    Still getting a segfault?
  3. Eraserhead macrumors G4


    Nov 3, 2005
    it works for me at least to connect to the Warwick UNIX servers with 10.4.7, i have XCode 2.3 installed too... I just did ssh to connect... I do have a PPC Mac, unless you have an Intel I suspect it's a problem with your server...
  4. macbook123 thread starter macrumors 68000

    Feb 11, 2006
    I do have an Intel Mac (see my signature). It's not my server either, since I can log on fine from my Linux laptop. I use Xcode 2.3 and OS 10.4.7. I've never seen ssh giving a "Segmentation Fault" message. Hope somebody will be able to diagnose this!
  5. plinden macrumors 68040


    Apr 8, 2004
    ssh is working fine on my Intel Mac after the update.

    If you type "ssh -V" what do you get?

    I see:
    OpenSSH_3.8.1p1, OpenSSL 0.9.7i 14 Oct 2005
    If you're getting a segmentation fault, presumably there's a core file somewhere. You can load this into gdb and try to find what's happening.
  6. macbook123 thread starter macrumors 68000

    Feb 11, 2006
    I do get the same if I just call /usr/bin/ssh:

    OpenSSH_3.8.1p1, OpenSSL 0.9.7i 14 Oct 2005

    However when trying to log on to any server, I get the segmentation fault message. As if ssh didn't like the format of the comman line option. I don't understand...
  7. macbook123 thread starter macrumors 68000

    Feb 11, 2006
    Using gdb, I'm getting the following but don't know how to interpret it:

    (gdb) run
    Starting program: /usr/bin/ssh

    Program received signal EXC_BAD_ACCESS, Could not access memory.
    Reason: KERN_INVALID_ADDRESS at address: 0xb1d2a484
    0x90b37e3a in __cxa_get_globals ()
    (gdb) bt
    #0 0x90b37e3a in __cxa_get_globals ()
    #1 0x90b3853a in __gxx_personality_v0 ()
    #2 0x90bcabf7 in _Unwind_RaiseException ()
    #3 0x90b38857 in __cxa_throw ()
    #4 0x94c5e238 in CCIContextDataMachIPCStub::OpenCCache ()
    #5 0x94c5dfde in CCEContext::OpenCCache ()
    #6 0x94c5dd5e in cc_open ()
    #7 0x94c5dbf6 in krb5_stdcc_resolve ()
    #8 0x94c631a1 in __KLGetCCacheByName ()
    #9 0x94c62e8a in __KLAcquireInitialTicketsForCache ()
    #10 0x94c62d7f in krb5int_cc_default ()
    #11 0x94c54215 in krb5_gss_acquire_cred ()
    #12 0x94c62d11 in kg_get_defcred ()
    #13 0x94c61a14 in krb5_gss_init_sec_context ()
    #14 0x00024305 in ?? ()
    #15 0x000246f4 in ?? ()
    #16 0x000247fb in ?? ()
    #17 0x0000c462 in ?? ()
    #18 0x0000a251 in ?? ()
    #19 0x000042c7 in ?? ()
    #20 0x000025f2 in ?? ()
    #21 0x0000250d in ?? ()
    (gdb) quit
  8. plinden macrumors 68040


    Apr 8, 2004
  9. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    I don't know how to solve the problem either, but I find the "status" of that thread to be somewhat... erm... fugazi.


    There is one thing I can contribute to this thread...the issue doesn't appear to have anything to do with the version of SSH... from my 10.4.6 iBook:

    The build didn't change with 10.4.7....
  10. macbook123 thread starter macrumors 68000

    Feb 11, 2006
    I don't know what you're referring to. In any event, I never checked the question to be answered. It is clearly not answered.

    After doing a combo update of 10.4.7 the problem has changed:

    OpenSSL version mismatch. Built against 90581f, you have 9060cf

    Interestingly, my partner has a Macbook, she also did the upgrade to 10.4.7, and ssh still works on hers. Also, somebody over on the Apple forum did the upgrade on his MBP 2.0 and it worked. So far the only other case of somebody having the problem is the link "plinden" provided. However there the problem apparently appeared under 10.4.6 and was solved with 10.4.7. It looks like this happens only in isolated cases. That's what's driving me nuts: that on some computers it seems to work on others it doesn't. How can this be a hardware problem?
  11. macbook123 thread starter macrumors 68000

    Feb 11, 2006
    o.k., since nothing else helped I did the 2.5 hour reinstall of the OS. Too bad one can't rely on updates of Mac OS. I know most people are probably happy with theirs and think this is whining, however it cost me probably 6 hours overall to go through this. There were other troubles caused presumably by 10.4.7 (since those were new to me): my MBP did freeze twice in the last 4 days, usually while doing simple browsing with Safari. Plus once the keyboard and mouse stopped working and only a PRAM reset saved me.

    To wrap up, unless someone very much needs one of the new features of 10.4.7, I would wait until it has been patched up a couple of times.
  12. Peace macrumors Core


    Apr 1, 2005
    Space--The ONLY Frontier
    Please list ALL the haxies you have installed..
  13. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    I'm sorry to say it, but this is my thinking too... this isn't a result of a problem with 10.4.7. This is a result of something else you installed on your system that confused the OS....
  14. macbook123 thread starter macrumors 68000

    Feb 11, 2006
    Hi, it's well possible that the second error I got, the mismatch between OpenSSL versions, was caused by all kinds of hacks I tried. However the first (Segmentation Fault) appeared after updating to 10.4.7, and wasn't there before. Note that I'm not the only one out there who has the problem. Anyways, of course I *hope* it is not due to a problem with 10.4.7, but just that I did something I don't remember. Take it easy.
  15. mforbes macrumors newbie

    Jul 5, 2006
  16. eureka macrumors newbie

    Sep 20, 2006
    Possible solution

    Dear all, I have just experienced the same problem with ssh in my macbook.

    I used the Darwin ports ( to install the new version of openSSL and openSSH.

    Simply type
    % sudo port install openssl
    and, after having done it
    % sudo port install openssh
    at the end of this second installation, a msg will tell you how to launch the new ssh at the startup; type it and restart your computer

    with it has worked fine.

    good luck!!!
  17. superbovine macrumors 68030


    Nov 7, 2003
    leave it to the newbie....
    openssl is broke, well let's reinstall it. ;) genius!
    ...but yeah that is what I would have done.
  18. dattilo0691 macrumors newbie

    Sep 26, 2006
    Work around for ssh problems...

    However it happened, this appears to be an issue directly related to a corrupt kerberos database/library which gets accessed when ssh v2 is instantiated. One solution is to find another Mac(book)Pro and replace the contents of:
    With the relative files from the machine with functional ssh.
    Hope that helps someone,

Share This Page