SSH Bugging Out

Discussion in 'Jailbreaks and iOS Hacks' started by ThunderApple, Dec 29, 2011.

  1. ThunderApple macrumors 6502

    Joined:
    Apr 27, 2010
    #1
    Downloaded Open SSH, SBSettings and it worked great yesterday.

    Today, whenever I click the SSH tab to turn it off, it changes to red. I click it again and nothing happens. It doesn't change back to green indicating that it's back on. It's really annoying me. I deleted SBSettings and downloaded it again but it's the same results. What's going on?
     
  2. noiceT macrumors 6502a

    Joined:
    Jul 7, 2008
    Location:
    Catalina Wine Mixer
    #2
    afaik there is an issue with ssh not working properly. The only way I got it to work is to reboot (depending on what you want it to do, on or off). Once you make a choice to ON, you cannot turn OFF until you reboot and click OFF.

    Annoying. But so far the only workaround that has worked for me.
     
  3. bushbabywas macrumors member

    Joined:
    Feb 9, 2011
    #3
    I had the same problem, but even if I turn the SBSettings toggle on, then reboot, it still doesn't work. I also tried using SSH Toggle off Cydia, and no luck.

    I thought this might have been connected to the problems Corona Untether was causing with the launchctl launchdaemon, but I've installed 1.0.3 (and re-JB'd with redsn0w b3) which was supposed to resolve that.

    Guess we're waiting on an update of Corona or Redsn0w?

    One question: if I want to go back to my tethered or semi-tethered 5.0.1 JB so I can get SSH back, how do I go about doing that? (please don't say this involves a restore!)
     
  4. Schnedi macrumors 6502a

    Schnedi

    Joined:
    Jan 16, 2011
    #4
    then i think no one will answer....

    and yes corona 1.0-3 or redsnow beta3 will solve the issue with openssh
     
  5. bushbabywas macrumors member

    Joined:
    Feb 9, 2011
    #5
    I am using Corona 1.0.3 and Redsnow beta3 and have rebooted, and the SSH problem is not solved, unfortunately. Insomnia (another launchdaemon) also does not display its statusbar icon properly, and its SBSettings toggle does not work right. So I assume there are still some launchctl/launchdaemon problems with the untether.

    So I cannot deactivate via redsnow and rejailbreak to get the old tethered JB back?

    If not I guess I'll just wait and see if any updates to Mobile Substrate, Corona or Redsn0w aimed at solving the SSH problem come out then. Wish I'd stuck with the semi-tether for a bit longer now!
     
  6. Schnedi macrumors 6502a

    Schnedi

    Joined:
    Jan 16, 2011
    #6

    that's really strange! i re-jailbroke with redsnow beta3 and then updated to corona v3 and all worked fine again...
     
  7. ThunderApple, Dec 30, 2011
    Last edited: Dec 30, 2011

    ThunderApple thread starter macrumors 6502

    Joined:
    Apr 27, 2010
    #7
    Crap, I used redsnow 0.9.10b1.

    But I still downloaded the Corona update the other day when it came out. Should I re-jailbreak using b3?? :confused:

    Can anyone tell me how to Jailbreak without the Install Cydia option? The only two things on redsnow is JB and Install Cydia and Extras.

    I'm hoping this fixes the SSH problem as well.
     
  8. ThunderApple thread starter macrumors 6502

    Joined:
    Apr 27, 2010
  9. wol macrumors regular

    Joined:
    Jun 15, 2005
    #9
    Not sure if I understand your problem - to cite from http://blog.iphone-dev.org/:

    Update #3: The b3 version of redsn0w fixes a problem where re-running redsn0w over an existing jailbreak would cause MobileSubstrate-based apps to stop running until MS was installed again. Now you can re-run the redsn0w jailbreak step without worrying about that (but still remember to de-select the “Install Cydia” option if it’s already installed).

    This is what I did - de-selecting “Install Cydia” once the option came up during the jailbreaking using redsn0w.
     
  10. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #10
    I found I needed to reboot to solve the ssh problem on my initial restoring to 5.0.1 after jailbreaking. That's your solution, not some Rube Goldberg method of getting back to a tethered jailbreak...
     
  11. bushbabywas macrumors member

    Joined:
    Feb 9, 2011
    #11
    no, as mentioned in some of the posts above, people are having SSH issues even after rebootin. no point in being snide.
     

Share This Page