SSH connection refused

Discussion in 'Mac Basics and Help' started by devburke2, Jun 10, 2018.

  1. devburke2 macrumors newbie

    Joined:
    Jun 10, 2018
    #1
    Well, this one's a puzzle for me.

    For years I've had this setup working perfectly. I had remote login turned on on my Mac, with a dynamic URL setup through DuckDNS, a consistent local IP address setup for my Mac, and port forwarding through my router so that I could remotely login via SSH from anywhere. I haven't connected to it in awhile, but when I tried today, it always just refuses the connection.

    If I'm just connecting to the local IP from within the network, it works just fine, so I think everything is setup fine on the Mac. But when I try and connect from outside the network, that's when it refuses (seemingly, it can't get through the router). This happened right after I upgraded the router firmware, so I figured that was the cause, but I tried downgrading the firmware, and it still didn't work. I've tried downgrades, factory resets, reflashes, etc., but still the same results. I even tried digging out an old Airport Express and using that instead of the same router, and it STILL didn't work! I tried connecting to two different Macs, I tried connecting FROM different machines, and I even tried connecting via VPN in case my ISP was causing any trouble.

    Still all the same results!

    I'm fresh out of ideas. I seem to have tried swapping every piece of the equation out, with no luck. And what's really strange is the entire setup used to work perfectly, and I didn't change anything.

    Does anyone have any ideas?

    Thanks!
     
  2. devburke2 thread starter macrumors newbie

    Joined:
    Jun 10, 2018
    #2
    I'm wondering if it could have something to do with a change in ISPs in recent months? It seems that even remote management of the router, which is enabled, doesn't work. I can't connect to it.
     
  3. Mikael H macrumors 6502a

    Joined:
    Sep 3, 2014
    #3
    If more ISPs get their ass in gear and deploy IPv6 networks, this could stop being an issue. Since the IPv4 address space is exhausted and "nobody" wants to invest in the competence required to deploy IPv6, more and more ISPs turn to NAT:ing entire customer neighborhoods, essentially turning an entire area into a local area network behind their own firewall which in that case is the only device with a real, Internet reachable address. It works nicely for all customers who just want to browse Facetwit or watch Huluflix, but if you want to present services from your home, you're out of luck.

    A possible alternative - which isn't free, though - would be to pay for a virtual private server (VPS) somewhere, and use it as a relay for SSH traffic; either using the built-in features of SSH, or via some kind of VPN solution (OpenVPN is free and powerful). Just make sure you secure your stuff properly...
     

Share This Page