Ssh? Ftp?

Discussion in 'iPod touch Hacks' started by stupendusboi, Dec 22, 2007.

  1. stupendusboi macrumors member

    Joined:
    Sep 8, 2007
    #1
    Hello, im sort of new to the "hacking" ipod c ommunity. I recently downloaded the pdf viewer and the the wallpaper.app which allows users to download photos to the "camera roll" file. Some people have said to Ssh and to Ftp to go into the root file which contains these pictures. Now, i do not now hat hte heck they are talking about LOL. can someone direct me how i can put my pdf files into the ipod touch and how i can view the camera roll files? thanks..
     
  2. jacktiernan macrumors regular

    Joined:
    Sep 3, 2007
    Location:
    Vic, Australia
    #2
    Welcome to the community :)

    SSH and FTP refer to a way of accessing the file structure on your ipod.

    You will need to have wifi and a computer

    I'm presuming you're on a mac.... im not at my mac right now, i'll check these instructions are correct when i get home in a few hours.

    Download cyberduck, open it and go to 'new connection' or 'open connection' or something

    Username = root
    Password = alpine

    For your IP address, go to your wifi settings on your ipod and click the arrow next to where it says your wifi network's name. There is a box on that screen that tells you your ipods IP address.

    ***Make sure you select "SFTP" and not "FTP" in the new connection screen in cyberduck or it wont work***

    Click 'connect'.

    If all went well you should now see your ipod file directory.

    Open the "Media_sym" folder, then "Applications" (i think..... i'm doing this from memory :eek:)

    You should see the "photo browser" folder.... put your pics in there i presume.

    Good luck. Let me know if that doesnt work and i'll double check the process


    :)
     
  3. stupendusboi thread starter macrumors member

    Joined:
    Sep 8, 2007
    #3
    im actually on a PC lol.. umm.. i hope its the same for the pc.. ill try it but dinner first :)
     
  4. stupendusboi thread starter macrumors member

    Joined:
    Sep 8, 2007
    #4
    Yeahh... cyberduckk is like for OSx i guess..does anyone have a guide for windows?
     
  5. Cetra macrumors newbie

    Joined:
    Dec 23, 2007
    #5
    For windows it's easy.

    Make sure that you have OpenSSH installed (through installer).

    After that download and install this program:

    http://winscp.net/eng/download.php

    This uses SCP, which is like FTP via SSH

    In the "Login" Screen of WinSCP type in the following details:

    Host name:

    The IP address of your iPod Touch,
    If you don't know what this is go to Settings -> Wi-Fi
    Click on the blue right arrow next to the name of your network and it will bring you to a page which will have your IP Address listed.

    Port number:

    Leave this as 22

    User name:

    'root'

    Password:

    'alpine'

    (don't include the quotes ;) )


    Then click Login.

    Note: If you get stuck and you can't log in or it says "host timed out" then you will need to do some diagnostics into why this is so. First off make sure the wireless network you are connected to allows for SSH traffic, i.e, no firewall, or appropriate settings...

    Secondly make sure you can ping the touch and the touch can ping you. To do this in windows. Click Start, Run, type in CMD. It'll bring up a black box and in there type in 'ping (insert ip here)'. For instance, 'ping 192.168.0.2' if your ipod touch's ip address is 192.168.0.2. You should normally receive a response like this:

    Code:
    Pinging 192.168.0.2 with 32 bytes of data:
    
    Reply from 192.168.0.2: bytes=32 time=416ms TTL=64
    Reply from 192.168.0.2: bytes=32 time=66ms TTL=64
    Reply from 192.168.0.2: bytes=32 time=90ms TTL=64
    Reply from 192.168.0.2: bytes=32 time=115ms TTL=64
    
    Ping statistics for 192.168.0.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 66ms, Maximum = 416ms, Average = 171ms

    If you can't and instead see "Request timed out." Make sure your iPod Touch can ping your computer. Install "Term-vt100" (it's under system) and run the command "Ping (insert your ip address)". To get the ip address in windows, click start->run, type in cmd and then in that box type in "ipconfig".

    If you receive a response from your computer on your touch, try pinging your touch from your computer again. It might start working. In which case if you can ping your ipod touch you should now be able to login with winSCP.

    After you have logged in you can see the directory structure,

    If you started winSCP in explorer view, you can just drag and drop files from explorer.

    If you started in in Norton Commander View, you can drag and drop from the left panel (which should be your drive).

    Hope this helps.
     
  6. RobT macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #6

    This worked, great, thanks a lot!
     
  7. Blood-Wraith macrumors newbie

    Joined:
    Dec 26, 2007
    #7
    I did all of that and it didn't work, my ipod touch wasn't able to ping my computer's ip address. Is it possible that this won't work if my computer is not on the same wifi network as my ipod touch?
     
  8. Cetra macrumors newbie

    Joined:
    Dec 23, 2007
    #8
    Yeah it most likely won't work if your touch is on another wifi network.

    Your best bet is to have your computer and ipod behind the same firewall/gateway/router. But it really depends on how the network(s) you're connecting to are set up.

    Most places probably wouldn't allow ssh traffic between two wireless subnets as it can pose a security risk.

    I would talk to whoever is in charge of your network and see if they're sympathetic to your cause ;)
     
  9. rgswff macrumors newbie

    Joined:
    Feb 2, 2008
    #9
    I'm having a similar problem. From my MBP I can't ping or ssh to my iPod but from my windows machine on the same network I can. Also, from my iPod I can't ping my MBP but can ping the windows machine. I guess something on my MBP is blocking the pings and connection to the iPod. I can ping the windows machine from the MBP though and it connects to the internet without any problems. I have the firewall set to allow all incoming connections. Any suggestions or things to check?
     
  10. rohitbaba macrumors newbie

    Joined:
    Nov 29, 2007
    #10
    issue with My Leopard OSX connecting to iphone on SSH.

    Hi

    I have issue with My Leopard OSX connecting to iphone on SSH.

    I have tried
    FUGU
    Cyberduck
    Filezilla

    But no luck.

    However my PC does connect via Winscp so i can only assume it problem with Leopard OSX.

    please let me know of any update. Email dhaval.natu@gmail.com

    Thanks
     
  11. bnizzy macrumors member

    Joined:
    Feb 4, 2008
    Location:
    NYC
    #11


    I was wondeirng, the part where the password is "apline" what if I had changed the password when i was doing the jailbreak to 1.1.3?? Is the password still apline or is it whatever I changed it to?
     
  12. thomas769 macrumors newbie

    Joined:
    May 11, 2008
    #12
    Attempted

    I can ping out from the computer to the ipod but not from the ipod to the computer. Say's operation is not permitted also using WinSCP and Putty it says the connection was denied/refused by the host.
    So me thinks there is something wrong with the ipod here.
    Am i supposed to have an icon for SSh on my iPod home screen. Like i do for installer and safari?
    Thanks in Advance.
    thomas769
     
  13. Cetra macrumors newbie

    Joined:
    Dec 23, 2007
    #13
    It's ran as a daemon so there is no icon for it on the springboard

    There are a few other things you can check.

    You can try connecting manually from your computer open up a command prompt and type in:

    telnet 192.168.1.50 22

    You should get a clear screen and response like:

    SSH-2.0-OpenSSH_4.6

    You can see whether it actually is loaded onto your ipod. First up, check installer to see whether the package is installed. click the uninstall button and under system you should see something like 'OpenSSH'

    Apart from that if you have a terminal emulator on your ipod (such as Term-vt100) you can load up a terminal to see if you can find the sshd executable. Load up term, login with the password if you have to, and type in this:

    whereis sshd

    you should get a line back saying something like:

    /usr/sbin/sshd

    You can check to see whether your ipod is listening for ssh requests on port 22 also from the terminal, type in this command:

    netstat -nap tcp

    This will show all active and listening TCP connections. You will get a bit of a jumble since the columns don't fit properly but what you should see is something like this:

    tcp4 0 0 *.22 *.* LISTEN

    (it will be wrapped along two lines)

    there may be other lines in there depending on other connections, but this is probably the most important one as it says your ipod is listening on port 22 for connections. Which means that you can probably SSH to it. If this is the case, check your pc's firewall or something, they can potentially block ssh traffic.
     
  14. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #14
    easiest way to upload and browse files on the touch on a pc is to google iPhoneBrowser, this allows you to upload, download, delete files and folders but it does not allow you to set permissions like you can using the likes of cuteftp.

    CuteFTP has a windows explorer style interface, setup a new connection with the ipod's ip address (this can change from time to time), set username root and password as alpine, then to set permissions is straight forward. Right click a file or folder and there will be a box with numbers in, just set them numbers to 755 (if not set already) and when done with file(s) just exit connection and reboot device
     
  15. donaldj macrumors 6502

    donaldj

    Joined:
    Feb 26, 2008
    Location:
    Ontario, Canada
    #15
    Seconded... iPhoneBrowser is by far the simplest method of viewing, and adding files. However the wireless ease of WinSCP is just brilliant. I love being able to lie in bet, log into my computer downstairs via VNsea, copy some songs, or videos onto my iPod via WinSCP, then play them through Safari.

    Ease of Relaxation, thine name is Apple iPod Touch.
     
  16. freeballer macrumors newbie

    Joined:
    Jan 22, 2007
    #16
    does the ipod have to be hacked prior to ssh

    okie all. question; I've tried to do the ssh/sftp into my ipod but is saying connection refused. So stupid question of day; does the ipod need prior jailbreak before this will work?

    Also if so, can someone direct me to an idiotproof method? perhaps a messenger or ssh program made for ipod touch as well? please

    Thanks,
    Freeballer
     
  17. donaldj macrumors 6502

    donaldj

    Joined:
    Feb 26, 2008
    Location:
    Ontario, Canada
    #17
    You need to be jailbroken for this to work.

    THIS tutorial was found at the top of this forum. They are there for your ease.
     
  18. freeballer macrumors newbie

    Joined:
    Jan 22, 2007
    #18
    package download failed / ZiPhone

    I downloaded and installed ZiPhone without incident, installer app is on the ipod's desktop and it downloaded the sources and gives me a list of apps. Problem is anything, I mean anything, I try to download i get "package download failed". most of the time is immediately after I click on install.. What should I do? Remove the installation from my ipod, format the ipod, or is there a way to download and install packages manually?
     
  19. opivy1218 macrumors member

    Joined:
    Mar 1, 2008
    #19
    Uhh, did you install community sources? If not do that, and if the problem persists, when you go to download something, press "Clear Cache". Either of those may solve your problem.
     
  20. freeballer macrumors newbie

    Joined:
    Jan 22, 2007
    #20
    community sources? can't say I have. the tutorial i found here said nothing about requiring new sources and the main site for the jailbreak has little to no info to help.

    http://guides.macrumors.com/Jailbreak_the_iPod_Touch

    Perhaps just looking wrong place, are there some good ones you all can share with a newbie, perhaps ones with pdf/ebook and divx support??

    edit: forgot to mention I've cleared the cache and tried refreshing sources to see if that'd work
     
  21. opivy1218 macrumors member

    Joined:
    Mar 1, 2008
    #21
    A good app I've come across is Repo Name. You just type in the name of the app you want, and it tells you the souce for the app.
    The source for Repo Name is http://davteam.com/repo.xml
    Also check out installerapps.com. It has a list of several applications available as well as the sources for them.
     
  22. 1776 macrumors newbie

    Joined:
    Jun 10, 2008
    #22
    For Mac it's even simpler, since OSX is partially based on FreeBSD. It already has a real, unix ssh client built in to it. Just open a terminal window and type:

    ssh user@host

    If you're going to use shell a lot, I highly recommend the shareware "Telnet Launcher". It let's you customize different fonts, colors, backgrounds, etc and host settings. It's pretty nice to just come in first thing in the morning and just click on the group you've defined to have 4 different shell windows to 3 different hosts automatically pop up and log in, sorted by font color.

    Now, If I could just find something similar for the IPT, I'd be really happy...
     

Share This Page