iPhone SSH-ing framework files

Discussion in 'Jailbreaks and iOS Hacks' started by saint berkut, Mar 29, 2013.

  1. saint berkut macrumors newbie

    Joined:
    Dec 16, 2011
    #1
    Hi MacRumors, I've SSH-ed and downloaded some files onto my mac specifically the next, play, pause, previous, previous disabled icons from iPodUI.framework, but for some reason only two files out of five are appearing properly. The other three files show up as blanks, but they appear in iFile.

    Anyone know what could be the problem? Just wanna edit some colors to tweak the music players UI a bit. Any answers are appreciated, thanks! :D
     
  2. everydayghost macrumors newbie

    everydayghost

    Joined:
    Mar 8, 2013
    Location:
    Australia
    #2
    Most of the files on your device go through an encryption process when they're put onto the phone which can only be read by your phone. I remember reading somewhere that you can do something with Xcode to remove the encryption, but my Macbook is out of date so I can't try it.

    A workaround is to find the image in iFile, save it to your camera roll, then copy it off the device as if it were a photo, or transfer it to dropbox (or a similar service). That's my process :)
     
  3. saint berkut thread starter macrumors newbie

    Joined:
    Dec 16, 2011
    #3
    Thank you! It works like a charm and I'm able to transfer those files without trouble. :D

    One more quick question, though. If I delete said files from their .framework location and replace them with identical, but edited, files with the exact same name I wouldn't run into trouble would I? The new files without the same encryption wouldn't have conflicts with existing files would it? :)

    Again thank you, I can't believe a simple, clever process escaped me. :D
     
  4. everydayghost macrumors newbie

    everydayghost

    Joined:
    Mar 8, 2013
    Location:
    Australia
    #4
    Replacing them with regular files will work fine. I believe the encryption is only there to make it harder to rip the default images from the system.
     
  5. saint berkut thread starter macrumors newbie

    Joined:
    Dec 16, 2011
    #5
    Thanks! Everything's working perfectly fine. :)
     

Share This Page