SSH into iPad Air (no jailbreak)

Discussion in 'iOS 7' started by ib2745, Mar 10, 2014.

  1. ib2745 macrumors newbie

    Joined:
    Mar 10, 2014
    #1
    I am a student and use an apple bluetooth keyboard with my iPad Air (7.0.6). Oddly enough, one day after walking home from class, I checked my iPad to review some notes I made earlier that day. I had thrown my iPad and my keyboard into my backpack, just as I have done for a long time now. However, I was surprised to find that my ipad was completely disabled, and I had to connect to iTunes.

    My theory of how this happened goes that as I walked home, random numbers were pushing against books in my backpack, and my iPad had not completely shut off. So after 10 incorrect combinations of numbers, my ipad bricked.:mad:

    Bummer, because I have never connected my ipad to any computer, and i did not jailbreak. So I am at loss as to how to recover the data off of the ipad. I would be okay with restoring to factory defaults, but I do research at my university, and i was not able to save my "Notes" and "Notability" files somewhere else in time. I have valuable data from long hours of research that I would like to recover if at all possible.



    So i am trying to figure out how to SSH into my iPad Air (iOS 7.0.6). I have tried via WinSCP, but I keep getting error messages "my device rejected the communication attempt" (not verbatim).

    Any help would be really really appreciated!!! I would be eternally grateful to anyone who could walk me through this! :)
     
  2. eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #2
    On iOS all your data is automatically encrypted. When you wipe your device for any reason iOS deletes the encryption key for all your data. There is no way to recover your data from a wiped device.
     
  3. ib2745 thread starter macrumors newbie

    Joined:
    Mar 10, 2014
    #3
    Hi! I would like to clarify that i have NOT restored my device yet.

    It is still in the disabled state. It says "iPad is disabled. Connect to iTunes." But hopefully there still is a way to access the root? Or at least some of the files?
     
  4. Corrie macrumors newbie

    Joined:
    Jun 12, 2013
    #4
    Have you tried connecting it to iTunes on your computer? I think this will reset the timer respectively unlocking your ipad.
     
  5. ib2745 thread starter macrumors newbie

    Joined:
    Mar 10, 2014
    #5
    There is no timer left, at least what I am aware of.. It just tells me to connect it to itunes. When I do that, it tells me to enter the passkey on my ipad, which happens to be locked. I think it's gotten to the point where there is no more timer, just an indefinite lock
     
  6. goobot macrumors 603

    goobot

    Joined:
    Jun 26, 2009
    Location:
    long island NY
    #6
    You can't SSH with out a jailbreak, did you have iCloud enabled on your device? If so you may have a backup of your device on there and your notes may have synced to it as well.
     
  7. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #7
    You cannot SSH into an unjailbroken iOS device because there's no SSH server running on it. The connect to iTunes when device is disabled message is designed so that you connect it to the computer your device syncs with. If you've never synced it with a computer, you'll have to restore it as a new device.
     
  8. ib2745 thread starter macrumors newbie

    Joined:
    Mar 10, 2014
    #8
    Haha well this makes me really sad :(. I guess I will probably have to do the restore. But before i do, there is NO possibility that i can save any data?

    I had iCloud disabled :'| The irony is, I was about to backup the ipad before it got disabled haha
     
  9. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #9
    Just wait a few hours. Mine did this on a trip; I thought my iPad was bricked until I got home from the trip, but when I picked it up the next morning it was happily asking me for the passcode.

    It was probably about five hours since I saw "Connect to iTunes" and it asked for the passcode again. Previous iOS versions used to tell you how long you're locked out for; I guess they took that out to make it more frustrating for people trying to guess passcodes.

    Also, if you leave Bluetooth keyboard paired to the iPad and the buttons get pushed in your bag it WILL do this. That's what happened in my case. Always turn off Bluetooth before packing the iPad with a keyboard.
     
  10. ib2745 thread starter macrumors newbie

    Joined:
    Mar 10, 2014
    #10
    Thanks for all the replies! It has been disabled like this for about 5 days, so it is probably too late to wait, right?
     
  11. The Doctor11 macrumors 603

    The Doctor11

    Joined:
    Dec 15, 2013
    Location:
    New York
    #11
    When it says enter the password on your iPad try and enter the password or your iPad on the computer. Sorry if you go to do that and it just looks like I'm being extremely stupid I have never had to plug in to iTunes for a password reason before. If that doesn't work try an take I to an apple store and have them show you how to do it.
     
  12. Jpauzie macrumors newbie

    Joined:
    Jul 16, 2014
    Location:
    Seatle,WA
    #12
    what mode are you stuck in?

    DFU Mode

    Recovery Mode

    Reboot Loop
     
  13. eelw macrumors 6502a

    eelw

    Joined:
    Sep 19, 2012
    #13
    Well 4 months later. Highly doubt the TC is still in recovery mode.
     
  14. iolinux333 macrumors 68000

    Joined:
    Feb 9, 2014
    #14
    What is going on with all the ancient threads being dredged up the past two days?!? Weird.
     
  15. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #15
    Somehow new users have a higher tendency to do that kind of thing for some reason.
     

Share This Page