SSH into iPhone via USB

Discussion in 'Jailbreaks and iOS Hacks' started by jthomp, Oct 20, 2009.

  1. jthomp macrumors regular

    Joined:
    Apr 4, 2008
    Location:
    the 717
    #1
    A few weeks ago using total commander, I was able to access my iphone files via a usb connection. I am now updated to jailbroken 3.1.2, and have tried everything to access the file structure. I am not able to use wifi here at work, but I can at home, so it's not a total loss. However, if i am in the mood to edit any files or data, I am stuck. I have tried the following programs with no luck:

    itunnel + winscp
    iphonebrowser
    total commander

    Does anyone know what i'm missing? Have things changed from previous OS version? Anyone have any better suggestions of an app to use?

    Thanks!
     
  2. Carl G35c macrumors 6502

    Joined:
    Aug 14, 2008
    #2
    I cant install programs here at work, but these may need itunes installed

    try funbox file browser, I use that on my home PC
     
  3. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #3
    I tunnel DOES work, you just need the right DLL files with it.

    Hang on I'll give you a version that works with the latest iTunes.

    It's iTunes 9.X and for iPhone OS 3.X. Worked for me.

    Oh, yea, and this DOES require iTunes to be installed.

    If all you want is File Browsing, then iFunBox does that quick and easy. This iTunnel is much more useful for SSH and VNC connections.
     

    Attached Files:

  4. jthomp thread starter macrumors regular

    Joined:
    Apr 4, 2008
    Location:
    the 717
  5. Blueline29 macrumors 68020

    Blueline29

    Joined:
    Jun 16, 2009
    Location:
    Windermere, FL
    #5
    I was just browsing through Cydia & discovered that some lovely person has created a package to easily add the afc2 service that's missing from blackra1n, too, which is what's causing all of the programs like iPhone Browser and DiskAid not to recognize the jailbreak. I messed around for hours yesterday trying just to be able to (once again) browse system files easily & ended up having to go in via iFile and add the missing code myself. I guess this package eliminates all of that work (not that it was a ton of work, but still.)
     
  6. m00p macrumors newbie

    Joined:
    Oct 21, 2009
    #6
    Mac OS X USB IP Access via Tethering

    When you use the built-in tethering and IP network is established, thus you can access all ports via the iPhone's IP -> 192.168.20.1 while it is connected via USB. So if you are running OpenSSH / AFP, you can have file system access via the finder, scp or MacFuse / MacFusion.

    A little patching of CommCenter is required, but there are also other ways to enable tethering again on 3.1.2.

    Here is more:

    http://ex.perimental.net/blog/index...-usb-mac-os-x-no-wifi-no-additional-software/
     
  7. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
  8. lawlist macrumors member

    Joined:
    May 19, 2010
    #8
    ssh via usb iphone mac osx python terminal cydia openssh

    For those users with a Mac computer who are Googling and looking for a method to ssh via usb to a current generation firmware iOS device (e.g., an iPhone 4.1), it is not only possible, but fairly easy to accomplish — you need two files — place tcprelay.py and usbmux.py in the same directory on the Mac (with tcprelay.py being chmod-ed so that it is executable, like 755) — from the terminal window inside the directory containing the two aforementioned files, type: ./tcprelay.py -t 22:2222 &

    For non-experts, you can then use a sftp client — the server is localhost, and the port is 2222. For ssh experts who use the terminal, you don’t need my help (I need yours). The files are here:

    https://github.com/gilir/usbmuxd-deb...python-client/
     

Share This Page