SSH not connecting on 3.0 ?

Discussion in 'Jailbreaks and iOS Hacks' started by hellomoto4, Jun 21, 2009.

  1. hellomoto4 macrumors 6502a

    hellomoto4

    Joined:
    Jul 11, 2008
    Location:
    Australia
    #1
    Hey guys,

    I tried to SSH tonight without luck.
    Using Transmit on my Mac and OpenSSH on my iPhone 3G, I tried to connect at root@192.168.0.9, with the password Alpine. I've double checked and yes this is my iPhone's current IP address. Yes, I am trying to connect via SFTP also.

    Anyway, I click connect and get this message:
    [​IMG]

    So, I click OK, and then 2 seconds later get the same message. And it repeats continuously until I click Cancel and it stops trying to connect.

    I'm not sure what exactly the Host Key is as I am new to SSH as of a couple of months ago, and don't/didn't use it often. Any ideas as to why I cannot connect, or is it due to 3.0?

    Thank you for your help :)
     
  2. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #2
    Finder > Go > Go to Folder... > ~/.ssh/
    Remove file known_hosts

    After that, if Transmit refuses to connect, use Terminal (/Applications/Utilities/Terminal) to ssh, by entering the following :
    Code:
    ssh root@[COLOR="Navy"]YOUR_IPHONE_IP_ADDRESS_HERE[/COLOR]
    Press the Enter/Return key
    Type in password: alpine
    Press the Enter/Return key

    PS: the password will not show as you type it... normal!

    Now Transmit should let you connect.
     
  3. bamabudman macrumors newbie

    Joined:
    Jun 13, 2009
    #3
    i cant connect either. ive tried everything i know to do.
     
  4. Nanook macrumors regular

    Nanook

    Joined:
    Dec 26, 2008
    Location:
    LA, CA
    #4
    Cyberduck returns the same error message, but it connects after I acknowledge it .
     
  5. dranakin macrumors 6502

    Joined:
    Mar 6, 2005
    #5
    Try this:

    1. open terminal
    2. type rm .ssh known_hosts
    3. press enter
    4. try to ssh into the phone again [through terminal]
     
  6. hellomoto4 thread starter macrumors 6502a

    hellomoto4

    Joined:
    Jul 11, 2008
    Location:
    Australia
    #6
    This worked perfectly, thank you so much! :)
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    It took me like 8-10 tries with Winscp to finally connect thru SSH.
    I had installed open ssh and restarted iphone but nothing would happen.
     
  8. BaseballMike macrumors newbie

    Joined:
    Jun 23, 2009
    #8
    I'm getting the following error when I ssh to my Jailbroken iPhone 2G:

    dyld: lazy symbol binding failed: Symbol not found: _login
    Referenced from: /usr/sbin/sshd
    Expected in: /usr/lib/libSystem.B.dylib

    dyld: Symbol not found: _login
    Referenced from: /usr/sbin/sshd
    Expected in: /usr/lib/libSystem.B.dylib

    Does anyone have any ideas? Also, my SBSettings isn't working entirely -- it crashes when selecting "More" (to customize it). And, Cydia won't run either (neither will BossPrefs) (though, Icy runs).

    Suggestions???

    Thanks.
     
  9. alilars macrumors newbie

    Joined:
    Jun 23, 2009
    #9
    You need to copy the "lockdown" folder.

    Go to....C:\Documents and Settings\All Users\Application Data\Apple\
    then copy the LOCKDOWN folder then go back to the direction
    C:\Documents and Settings\username\Application Data\Apple Computer\
    and paste it there. Then log in with the same username, ip and pass and it should work.
     
  10. BaseballMike macrumors newbie

    Joined:
    Jun 23, 2009
    #10
    I am using ssh from my Mac, not WinSCP or something else.

    Also, this error is being thrown on the "server" (it was referenced from sshd which is running on the iPhone)?

    There's something very screwy about the state of my iPhone I believe....
     

Share This Page