SSH not working in 1.1.3

Discussion in 'iPod touch Hacks' started by Jakintosh™, Feb 4, 2008.

  1. Jakintosh™ macrumors member

    Joined:
    Jun 21, 2007
    #1
    well after like three days of trying to fix it, i still have gotten nowhere. does anybody know why ssh wont work? im using cyberduck, 1.1.3 Dev team (pretty sure, my SB works and cust doesn't) and yes i have open SSH installed. Bossprefs says its on, but i can't connect... please respond asap.
     
  2. doomnote macrumors newbie

    Joined:
    Nov 7, 2007
    #2
    The easiest way is to go up to the Bookmarks menu and then Bonjour - your iPod should be there. Then you don't have to mess with typing in IPs or anything else.

    The very first time you try to connect it should time out a few times. It gives you this warning when you first download openSSH. After that make sure you use username: root and password: alpine.


    What exactly is happening when you try to connect?
     
  3. jcs1088 macrumors regular

    Joined:
    Oct 12, 2007
    Location:
    Las Vegas, NV
    #3
    i used root/ dottie for my username/ password. the weird thing was on the main window i used dottie and window would pop up saying login failed enter password and i tired alpine and it worked. i used different combinations until i got it.
     
  4. Four20 macrumors 6502a

    Four20

    Joined:
    Sep 22, 2007
    #4
    did you disable SSH with services? or itoggle? if so then because of the root/mobile issue it won't turn back on

    uninstall openssh and reinstall it

    but as long as you don't get an immediate 'connection refused' then it's just generating the key(s). . .just wait until it goes through

    . . .but if you do get a connection refused error then yes SSH isn't running and something else is going wrong.
     
  5. Jakintosh™ thread starter macrumors member

    Joined:
    Jun 21, 2007
    #5
    wow this is really sucking. i can barely do ANYTHING without my ssh, and i can't even redownload it now.... is there a way to access it withtout wi-fi on a mac? (not touchexplorer) then maybe i can do something, but right now, this thing is practically as useful as a jailed 1.1.3....
     
  6. FearedBliss macrumors member

    Joined:
    Nov 25, 2007
    #6
    Well your supposed to have BSD Subsystem installed so make sure you installed that. After that install OpenSSH and install Services or BossPrefs so you can turn on SSH. Then type in Terminal:

    Code:
    ssh root@IP
    username: root
    password: alpine

    It might be a permissions error, if it is, then you have 2 choices,

    1. Reinstall
    2. Install Term-vt100
     
  7. Jakintosh™ thread starter macrumors member

    Joined:
    Jun 21, 2007
    #7
    okay, well, i downloaded that app called like IP or something, and it turned out that my ipod had 2 ip addresses. one was the one that showed up most places, 192.X.X.XXX and one that didnt, 127.X.X.X and i went into cyberduck and used the 127.X.X.X and it worked! but the only probelm was, it didn't accept my password and or user name. so far i tried

    root
    alpine

    root
    dottie

    mobile
    alpine

    mobile
    dottie

    and none of thes worked. does anyone know what password combo i should be using for 1.1.3? please respond asap
     
  8. Jakintosh™ thread starter macrumors member

    Joined:
    Jun 21, 2007
    #8
    haha im going crazy. i finally got OpenSSH to download, and cyberduck still won't work hahaha. iv done EVERYTHING and i just can't ssh into it. every pass word, every username. every ip address. i even used the macfusion thing too and that does the same thing. im gonna go throw my ipod out the window.
     
  9. chrisbeebops macrumors regular

    Joined:
    Jun 8, 2007
    #9
    127.0.0.1 is a loopback address. Anything you send to this IP address gets sent back to you. You are trying to ssh into the computer you are typing the command on.

    192.168.x.x is your lan IP address. All computers that are part of this network will see your iPod at this address. If the ssh request fails, then ssh is disabled or non-functional on your iPod.
     
  10. Jakintosh™ thread starter macrumors member

    Joined:
    Jun 21, 2007
    #10
    haha yeah i noticed something was up with that 127 cuz it worked when wi-fi was off lol. but any way, my ipods ip address is not a 192.xxxxxxxxx it is a 10.X.X.XXX address. it worked before i upgraded to 1.1.3, but im not sure what is wrong now...
     
  11. bnizzy macrumors member

    Joined:
    Feb 4, 2008
    Location:
    NYC
    #11
    try using
    user: root
    pass: 123456

    i dunno if that will work, but worth a shot.

    and that 10.XXXXXXXXX is an odd IP address...

    I just barely got my cyber duck to work.. I had to redownload Open SSH after 1.1.3 JB, and i went thru re-JB several times... more than anyone should have to go thru. i feel your pain.
     
  12. FearedBliss macrumors member

    Joined:
    Nov 25, 2007
    #12
    I'm 99% sure thats not your IP address. Usually routers have 192.168.1.x or 192.168.0.x, check your routers main page and see if your iPod is getting detected. Also you can go into Settings -> Wi-Fi -> <NETWORK connected> and you will see the IP address your iPod is using.
     
  13. Jakintosh™ thread starter macrumors member

    Joined:
    Jun 21, 2007
    #13
    yeah i know thats a weird IP address, but the setting on my router are like - IP prefix (or something like that) is set to 10. and that is the IP address of my mac book too 10.0.1.198, my ipod is usually 10.0.1.199, so that is my address, but maybe i should change it, cuz if i connect to a neighbors wifi, (ip begins wit 192,) it works...
     
  14. JamieKitson Guest

    #14
    I uninstalled OpenSSH, reinstalled the BSD SubSystem and then reinstalled OpenSSH. Worked for me.

    btw, 10.x.x.x ip addresses are not weird, they're also internal ips, it just happens that most routers default to 192.168.x.x addresses.
     
  15. edmarvis macrumors newbie

    Joined:
    Feb 14, 2008
    #15
    Media Folder Disappeared

    I ssh my ipod with 1.1.3 jailbreak but the media folder is not there anymore, and in the library folder there is just two files!!!
    and plus the customization with sbd doesn't work at all!!!

    Help Please
     
  16. Darkjenso macrumors regular

    Joined:
    Oct 27, 2007
    #17
    one thing i used to do is if i was on the go, and wanted to connect to my ipod, was i would create a new network, then SSH to my ipod via that, since i have upgraded to 1.1.3, i have also not been able to even use this method via SSH, it times out instantly
     
  17. theman macrumors 6502a

    Joined:
    Jul 26, 2007
    #18
    i can't ssh either, i always get this message:

    ssh: connect to host 172.xxxxxxxxx port 22: Operation timed out
     
  18. jbarr macrumors regular

    Joined:
    Feb 17, 2008
    #19
    Is there a firewall on your Mac?

    Do you get a response from pinging your IPT's IP?
     
  19. theman macrumors 6502a

    Joined:
    Jul 26, 2007
    #20
    my router has a firewall, i tried opening port 22 but it still wouldn't work. for some reason it worked ONCE on my PC but the second time i did it it failed...
     
  20. jacktiernan macrumors regular

    Joined:
    Sep 3, 2007
    Location:
    Vic, Australia
    #21
    Had the same issue, reinstalled OPENSSH and all working fine now :)
     
  21. donaldj macrumors 6502

    donaldj

    Joined:
    Feb 26, 2008
    Location:
    Ontario, Canada
    #22
    May seem silly...

    This may seem silly, but I had the same problem for an hour, I ended up figuring out that your iPod had to be ON (as in, not in 'sleep mode').... there has to be something showing on your iPod's screen to connect.

    Sorry if this insults you...
     
  22. Spiderman1490 macrumors newbie

    Joined:
    Feb 20, 2008
    Location:
    Oklahoma
    #23
    what exacley is ssh? the guy i had bought my itouch from jail broke it at 1.1.2 and had it on there...i could never figure out what it was for... i updated to 1.1.4. if it's something i would like to have after i figure out what it is how would iget it back? j/w
     

Share This Page