SSH Not working. Need some help

Discussion in 'Jailbreaks and iOS Hacks' started by pinter, Nov 10, 2010.

  1. pinter macrumors newbie

    Joined:
    Aug 14, 2010
    Location:
    Canada
    #1
    Hey all.

    Well I upgraded to IOS 4.1 about 2 weeks ago and ran a aptbackup backup and it restored most applications however SSH does not work. I can uninstall ssh and reinstall it and it will works until the phone is reloaded or rebooted and then it no longer works.

    Anybody know how I can go about fixing this issue as it is annoying and I would like it to be resolved.

    Thanks
     
  2. pinter thread starter macrumors newbie

    Joined:
    Aug 14, 2010
    Location:
    Canada
  3. pinter thread starter macrumors newbie

    Joined:
    Aug 14, 2010
    Location:
    Canada
    #3
    Bump

    Anybody have any suggestions? Maybe a forum that actually helps people?
     
  4. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #4
    With a great attitude like this I'm sure people will be jumping to help you.

    Are you sure when you are trying to connect that your phone is actually connected to WiFi? Try opening up Safari and make sure the 3G/Edge symbol pops over to WiFi before you try to connect. Also, download SBSettings and make sure SSH is turned on (though it's supposed to be by default when the phone boots)
     
  5. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #5
    Try installing Automatic SSH, which helps reconnect a lost connection.
    Are you checking in SBSettings that its not somehow being turned off on a reeboot?
    P.S. people love helping anyone who is so vitriolic, so keep it up!!
     
  6. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #6
    Which jailbreak software did you use? GP or LM? If you used a beta version of Limera1n that's your problem. You need to install afc2add.
     
  7. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #7
    First at all, Bumping is against forums rules.

    Second if you want anyone to help you, you need to provide more details than just "it is not working" otherwise there is no way to give you an intelligent answer.

    How do you know is not working? Do you get an error? Do you have an screenshot? is SSH running on the phone? what SSH client do you use? what "other" SSH clients have you tired? have you tired using a different computer? Are you behind a Firewall? are you using Windows, Mac or Linux?

    there is a infinity amount of reason why your SSH is not connecting or not working or simply just not starting after reboot, please provide more details so we can help you.
     
  8. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #8
    Seriously? Limera!n used here and SSH is perfectly stable. Perhaps you've heard of a couple of LR issues, but most of us that did the TU/Limera1n upgrade are as stable as can be.
     
  9. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #9
    Yeah in the beta versions of Limera1n, GeoHot didn't have the afc2add in the code and there were a lot of bugs. The latest version of LP (rc1b?) fixes all those issues.
     
  10. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #10
    Fair enough, so two weeks ago when the OP upgraded the final version of LR was out for quite some time. Doubtful that is the issue, but it's good to know and eliminate as a possible cause.
     
  11. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #11
    If the OP did use LimeRa1n, he can re-run the newer version over the old one and his iPhone will fix.
     
  12. pinter thread starter macrumors newbie

    Joined:
    Aug 14, 2010
    Location:
    Canada
    #12
    Hey all,

    I am sorry for not providing more information but here you go.

    My phone has IOS 4.1 and was jailbroken with Green Poison and the file I downloaded is called gp_win32_rc4.

    I ran the JB and Cydia was installed. I used APT backup to reinstall my old apps from 4.0.1 and shh was working fine as I edited the hosts file. I then rebooted and went to ssh again and it gives me an error saying "Network Error. Connection refused and I am using Putty as a client.

    - My SBS toggle for SSH is enabled.
    - I have no firewall
    - I tried on my computer with Windows 7 and my work computer which is XP and same error
    - I am positive it is connected to the wireless as I can disable data and phone and I will still be able to access my email and web pages and I can also ping and confirm via mac address with the wireless router.

    If I uninstall reboot and reinstall openSSH, it works fine until I reboot and then it no longer works. I have tried connecting from a Linux PC via command line also and it gives the same error.

    I have no clue what the issue is but it sucks as I need to ssh back into my phone. I have googled to kingdom come but not came across this same error.

    I tried looking in Cydia for afc2add and no luck.

    SO any help is appreciated as I am lost.

    edit:

    Just tried to connect again and error is server unexpectedly closed network connection.
     

Share This Page