ssh on 2.1 - problems getting sshd running

Discussion in 'Jailbreaks and iOS Hacks' started by bobdobbs, Oct 12, 2008.

  1. bobdobbs macrumors newbie

    Joined:
    Jul 20, 2008
    #1
    Hi all.

    I recently got my iphone updated to 2.1, using pwnagetool.
    I then used cydia to install openssh.

    Trouble is, I can't seem to get sshd running on the iphone.

    First of all, I couldn't connect to the iphone via ssh.
    I discovered that sshd wasn't running on the iphone.

    I opened up a term on the phone and tried "sshd".
    I got an error message saying that the absolute path was required to run sshd.

    So, I did 'which sshd'. This returned the absolute path:
    /usr/sbin/shhd.

    I tried running sshd by typing the whole path, but then got an error message saying that the host key couldn't be loaded.

    How do I get shh and sshd running on my phone?
    Its never been this much of a task on previous versions of openssh for the iphone.
     
  2. SelfMadeCelo macrumors regular

    SelfMadeCelo

    Joined:
    Sep 9, 2008
    Location:
    Tulare, CA
    #2
    I used BossPrefs to turn OpenSSH on and off, if that helps at all. Kind of new to jailbreaking iPhones.
     
  3. bobdobbs thread starter macrumors newbie

    Joined:
    Jul 20, 2008
    #3
    I thought of that.
    I figured that bossprefs would have some kind of magic in it that could get the daemon started.
    So, I installed it.
    But, no luck.

    Bossprefs actually showed the ssh service as running when it wasn't.
    When I used bossprefs to turn ssh off and then on again, it still woudn't actually run.

    I confirmed this by using ps.
     

Share This Page