ssh problem in mavericks

Discussion in 'OS X Mavericks (10.9)' started by linuxophile, Nov 14, 2013.

  1. linuxophile macrumors regular

    Joined:
    Nov 8, 2005
    Location:
    here
    #1
    Hello guys,
    I have a minor problem:
    after upgrading to 10.9 I cannot ssh from outside.
    In fact I cannot ssh into 127.0.0.1 (i.e. even locally). I am prompted with password: but after three times I enter it, it gives an error (something about public key).

    Remote login is enabled.

    I have found that admin accounts do not have the same problem (so the solution is: make myself admin and then it works).

    Still I see no reason why. It worked before for regular accounts as well.
    I imagine it is some permission issue (but repairing does nothing).
    I prefer to have my regular account without admin privileges.

    It is conceivable I need to change some configuration in /etc/ but I have long forgotten these things.
    Any ideas?
     
  2. linuxophile thread starter macrumors regular

    Joined:
    Nov 8, 2005
    Location:
    here
    #2
    Solution found

    Hi there: just in case someone else lands here.

    I was silly (but Apple was too): in the "Remote Login" pref pane there is a list of authorized users.
    When upgrading this list is reset to only admins:
    I did not notice it at first (and assumed that all the settings were migrated in the upgrade; well, not all!).


    Therefore it suffices to re-add yourself (and whoever else) to the list.
     
  3. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #3
    First: Great to know you got the problem resolved.

    Second: THANK YOU for posting the solution to your own thread! So many times I've googled an issue, found someone else with the same problem in a forum like this, only to see it ended with "never mind, fixed it," and never posting what they did to fix it! :confused:

    More people who end up self-solving need to do exactly what you did. :)
     

Share This Page