SSH Problem

Discussion in 'Jailbreaks and iOS Hacks' started by sanctifi3d, Mar 8, 2010.

  1. sanctifi3d macrumors newbie

    Joined:
    Mar 8, 2010
    #1
    Hi I'm having a problem I just restored my phone and only installed openssh,sbsettings, and some apt 0.7 update. I restored because of this ssh problem.. and it's back again :(

    my problem is after installng openssh I can use ssh for about <10 mins then it disconnects.. After that I can't connect anymore it gives me this error:
    Code:
    ssh_exchange_identification: connection closed by remote host
    it only works again after I reinstall openssh and openssl, but always disconnect after <10mins then back with the problem again.. I tried restoring a few times only installing sb settings and openssh(w/ openssl) then the other "essential upgrades" I already tried to remove known_hosts,check allow.hosts and deny.hosts, restores,etc I tried a whole lot of things with help from other people too I just cant make it work please help me I'm out of ideas/options

    I have an Iphone 3g 3.1.2
     
  2. sanctifi3d thread starter macrumors newbie

    Joined:
    Mar 8, 2010
  3. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #3
    Make sure you have Settings > General > Auto-Lock set to "Never"
     
  4. ngenerator macrumors 68000

    ngenerator

    Joined:
    May 12, 2009
    Location:
    USG Ishimura
    #4
    Agreed, it sounds like your program is being kicked out by the auto lock function on your phone.
     
  5. sanctifi3d thread starter macrumors newbie

    Joined:
    Mar 8, 2010
    #5
    that's not the problem cause I can see it disconnect on mobile terminal (I ran "ssh root@localhost" on mobileterminal) meaning it's not locked when it disconnects
     
  6. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #6
    Try installing automaticSSH as well.
    This should reconnect your SSH automatically after a disconnection.
     
  7. sanctifi3d thread starter macrumors newbie

    Joined:
    Mar 8, 2010
    #7
    tried that it doesn't affect it.

    I tried getting my iphone replaced telling them that I have some issues downloading big files but since I can't make that problem happen at the store they wont replace it :(
     

Share This Page