SSH Problems

Discussion in 'Mac Apps and Mac App Store' started by wakerider017, Oct 14, 2007.

  1. wakerider017 macrumors 68000

    wakerider017

    Joined:
    Sep 20, 2006
    Location:
    US of A
    #1
    In terminal I am getting this message after this command "nick-talsmas-computer:~ talsma$ ssh -l root 192.168.1.101" :


    How do I fix this?
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    You have to edit the .ssh/known_hosts file. You're going to need to delete the entire for that IP/hostname.

    It sounds like the machine you're trying to ssh into has had hardware change.
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    Yea that happens when the security certificate expires. I've had it happen with my machines. You can delete out the entry for that machine from the file "~/.ssh/known_hosts" You can edit the file in any text editor. Once deleted it should give you the option to accept the security certificate.
     
  4. moteltan macrumors newbie

    Joined:
    Jan 5, 2008
    #4
    remote host ID has changed.

    I have beaten my brains out trying to get around this problem. I CMD+SHIFT+G to .ssh and delete the file, still get the "WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!" I even "ssh -1 frontrow@10.0.1.199" to add the current key and it fails. I cannot get this script to run on my apple tv.
     

Share This Page