SSH problems

Discussion in 'Jailbreaks and iOS Hacks' started by jshelton, Jul 21, 2009.

  1. jshelton macrumors 6502a

    Joined:
    Aug 4, 2008
    #1
    I followed the directions from Cydia and tried to get familiar with SSH.

    I opened Terminal on my MB and typed ssh root@<ip address>,
    and then hit enter.

    It stalled for a second and then brought up some type of warning. It asked for a password. I tried to type but the cursor was locked up.

    I just quit Terminal. Did I mess anything up with my iPhone or Macbook?

    I didn't need the SSH, I was just curious.
     
  2. foob macrumors 6502

    foob

    Joined:
    Feb 17, 2009
    #2
    I haven't used a Mac, but on other computers and the phone, the cursor won't move when you type the password. Although the letters are really being typed, nothing shows.
     
  3. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #3
    Type "alpine" without the quotes, then press return. The cursor doesn't work, but it knows what your are typing.
     
  4. jshelton thread starter macrumors 6502a

    Joined:
    Aug 4, 2008
    #4
    Well, that explains that then. So did I mess anything up by stopping there and just closing Terminal?

    Thanks for your help.
     
  5. thep33t macrumors regular

    Joined:
    Jun 18, 2009
    #5
    You didnt mess up anything by stopping there. However, with your limited knowledge of the command line, I would recommend you be extremely careful with what you do, or a restore will be in order for you.
     
  6. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #6
    If you just want to move themes and mods in an out of the phone, get CyberDuck.

    Using the MobileTerminal on the phone is not necessary very often.

    If you do decide to do stuff on mobile terminal, as soon as you open it type su (for Superuser) hit return
    Type alpine (it's the password) then hit return

    Now you will be authorized to do anything, but as stated, be careful.
     
  7. jshelton thread starter macrumors 6502a

    Joined:
    Aug 4, 2008
    #7
    My knowledge of the command line isn't limited, it is zero.

    By a restore, you mean the iPhone, not the computer, correct? I can always restore the iPhone, I just don't want to cause a problem with my MBP.
     
  8. ldobson macrumors regular

    Joined:
    Jun 19, 2009
    #8
    No you didnt break anything with the iPhone, heres what happened

    You: ssh root@<ip address>
    Your Phone: hello, please enter the root password
    You: <close terminal>
    Your Phone: *shrug*

    Yes, the most you could do is screw up the phone which would require you to do a full restore on your phone, wouldnt impact your computer whatsoever.
     
  9. jshelton thread starter macrumors 6502a

    Joined:
    Aug 4, 2008
    #9
    Ha! Nice.

    Ok then, I suppose I should shy away from Terminal from here on out. Thanks everyone.
     

Share This Page