SSH what am I doing wrong?

Discussion in 'Jailbreaks and iOS Hacks' started by xanders, Aug 22, 2010.

  1. xanders macrumors member

    Joined:
    Jan 31, 2010
    #1
    I have a JB Iphone 3gs running ios4. Cydia has OpenSSH installed (green tick mark) I have Cybderduck installed on my Macbook. I enter IP address root, password alpine etc but I keep getting Cannot Connect message. What am I doing wrong??? :confused:
     
  2. Rydinsmoothx macrumors newbie

    Joined:
    Jul 14, 2010
    #2
    make sure sftp (ssh) is selected where u see file protocol
     
  3. xanders thread starter macrumors member

    Joined:
    Jan 31, 2010
    #4
    Have done that too...
     
  4. Dammit Cubs macrumors 68000

    Dammit Cubs

    Joined:
    Jul 31, 2007
    #5
    1) download cyberduck
    2) Download SSH client on Iphone
    3) unlock your phone, (keep your phone unlocked, Locked Closes connection)
    4) Wifi connection to phone.

    lookup your ip address:

    type: SFTP

    User: Root
    Password: alpine.
     
  5. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #6
    I keep seeing this statement made in various posts. But my iPhone 4 never closes the SSH connection unless the WiFi connection is lost or I manually close it. Locked or unlocked it doesn't matter. I have had the connection open overnight before.

    Did this change recently? Or is this some kind of false "truth" that gets spread around?

    S-
     
  6. oSutrooper macrumors member

    oSutrooper

    Joined:
    Jul 15, 2007
    Location:
    Denver, Colorado
    #7
    I think I understand what you are saying, make sure that you do the following

    Settings---General-----Auto-Lock---- CHANGE THIS TO NEVER and then at the top hit the general button. As long as the phone doesn't lock then the connection will stay open.

    Hope this helps
     
  7. xanders thread starter macrumors member

    Joined:
    Jan 31, 2010
    #8
    I am doing the above, only I use OpenSSH on Cydia. Do I have to turn 'on' something??
     
  8. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #9
    have you turned on SSH via SBSETTINGS?

    if you have sbsetting installed on your iphone you can toggle SSH on/off. your IP address will also be displayed note that the IP address can change from time to time! (i.e. 192.168.1.101/102/103 etc!)
     
  9. DouchGod macrumors regular

    DouchGod

    Joined:
    Aug 23, 2010
    #10
    My iphone fails to connect if the screen is locked. It has caught me out a few times.lol
     
  10. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #11
    When my phone locks, the wifi reverts to 3G. I think this is why they are stating that. I know it’s supposed to be persistent wifi, but the jailbreak seems to have changed that.
     
  11. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #12
    My ability to SSH remains overnight via wi-fi. I never leave my 3G on unless I intend to use it.
     
  12. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #13
    I have 3G on and WiFi set to connect to known networks automatically but not set to ask to join new networks.

    Regardless, I am happy I don't have this issue.

    S-
     
  13. xanders thread starter macrumors member

    Joined:
    Jan 31, 2010
    #14
    I have installed SBS Settings re-installed Open SSH. Now I see the icon on SBS and turn in on. And I still get an error "premature connection close" any help?
     
  14. kre62 macrumors 68000

    Joined:
    Jul 12, 2010
    #15
    Why does any one even SSH when they can just use iFunBox? So easy to use, no ip addresses or even openssh installed on your phone. Drag and drop.
     
  15. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #16
    iFunBox is a fancy file manager. SSH is sooo much more.

    Good luck using iFunBox without your USB cable as well. Right now I'm SSH'd into my phone via the Bluetooth that I am tethering with (I could also use it via WiFi). Also, my Snow Leopard has problems when I try to feed it anything Windows flavored.
     
  16. kre62 macrumors 68000

    Joined:
    Jul 12, 2010
    #17
    I mean, I would need SSH to simply access my files and install new ones. What other functionality does SSH give me that is actually useful? And I personally prefer using a usb cable. Faster transfers, feels more secure.
     
  17. esadb macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #18
    You got the ikey worm.. Some worm that shuts off SSH at intervals i guess you can look around this forum for it or google. I had that exact same issue 2 nights ago. Same setup too, macbook, cyberduck. Was getting premature connection..

    Get ifile and go find and delete this file..

    /System/Library/LaunchDaemons/com.ikey.bbot.plis

    Reboot the phone and go back and SSH should work fine using root:alpine, might have to reinstall SSH after you delete the file just for safe measures cant remember.

    But report back
     
  18. xanders thread starter macrumors member

    Joined:
    Jan 31, 2010
    #19
    This is it!

    Superb! This worked!!! Thanks a ton... wonder where the worm came from??
    :D
     

Share This Page