Standard account can't modify files in own Documents folder

Discussion in 'macOS' started by paragonj, May 7, 2008.

  1. paragonj macrumors member

    Joined:
    Jan 16, 2008
    #1
    Hello,

    I'm trying to set up a standard account for my girlfriend on my MBP, but when I try to change any files on her desktop or documents folder, it says I don't have sufficient permissions (when logged in as her). I checked the permissions and it says she has read/write privledges. Does anybody know what could be causing this and how to fix it? Thanks for the help.
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    are you trying to modify her Desktop and Documents folder while logged into your account?

    that wont work as by default OS X applies strict permissions to a user's folder so other users cannot modify the default folders in the their home directory… except the Root user which can be enabled in Directory Utility or by using "sudo" in Terminal, but if you dont know what this means dont worry ignore me :p.

    you should just be able to click authenticate on the dialgue box that appears then input you admin password.

    but if that doesnt work get info on the folder by clicking it and pressing "command-I", open the Sharing & Permissions arrow, click the lock and enter your admin password and then give everyone read/write access or add yourself and give read/write access.
     
  3. paragonj thread starter macrumors member

    Joined:
    Jan 16, 2008
    #3
    I'm logged in as HER account, not mine. That's what's baffling. In get info, it says she has read/write access.
     
  4. patochan macrumors newbie

    Joined:
    Jun 13, 2008
    #4
    Did you fix that problem? It's been a month, so I thought maybe you have already. I had the same problem and it's been almost a year since I fixed it, so hopefully you're faster than I am. I upgraded to Leopard and all my old files (which I owned) got copied over and I couldn't edit them! I don't remember what I did to work around the issue, but I think I must have so many files I don't use that I just ignored all the old ones and just used new files.

    Anyway, today I was so frustrated, I searched again and I found a link that actually worked and even explained the problem. It's basically the ACLs and the "apply to all enclosed files". I followed the commands in the post http://discussions.apple.com/thread.jspa?messageID=7239576&#7239576 and it worked perfectly. There's no sudo-ing to be done and nothing to break, just log in as the user and do these commands. It worked and I'm so thankful -- too bad I waited so long to find it!
     

Share This Page