Star TSP600 POS printer on Mac

kflux

macrumors newbie
Original poster
Jan 18, 2012
2
0
hey folks,

i recently got a Star Micronics TSP600 thermal POS printer (TSP613 tear bar type with serial interface) which I am trying toget to work on my Mac via a USB to Serial adapter (PL2303 chip)

Having done some research on this topic many people simply said to buy a USB model and stop trying to get a serial printer run. I didn't like that approach, so I tried it.

I actually got to the point where my printer spits out unreadable gibberish (heureka!!!) but i don't really know why - and I might need some advice from a CUPS/POS guru or simply from someone who has successfully achieved to get such a printer to run...

here's what i did so far:

- installed open source PL2303 USB-to-Serial driver that was recommended here (seems to work, because it shows up in /dev/tty*)

- since Star Micronics doesn't provide a Mac driver for the serial TSP600, but only USB, i went on to find a CUPS PPD file for this printer - which i found in the Linux driver package for the same model (tsp613.ppd.gz)

- installed the Serial Printing Enabler from here

- went to my local CUPS settings page http://localhost:631 to "Administration" > "Add Printer"
- set name and description > next picked "PL2303-XXXXXX" (USB-to-Serial-adapter) as device
- set 9600 bps, 8 bits, no parity, DTR handshake as settings (same as my printer)
- chose the downloaded tsp613.ppd driver file for this printer
- finish

the printer showed up in CUPS and in the MacOS X printer settings as "TSP613 Tear Bar" and i tested it by printing a simple text file, but nothing at all happened...so i went back into the CUPS settings and changed the serial handshake to "none" and tried printing again - and it WORKED!!!!!!

err, the TSP600 spit out inches and inches of paper filled with lines of ASCII gibberish, but at least my Mac speaks to the printer now!

i need a hint where to continue! is it a serial settings issue or is it a CUPS driver issue? any more ideas would be highly appreciated!

thanks in advance,

flux
 

gsahli

macrumors 6502a
Jun 1, 2007
646
22
Chicago
i went on to find a CUPS PPD file for this printer - which i found in the Linux driver package for the same model (tsp613.ppd.gz)
I think you're close!
Take a look at the text version (ie, not .gz) of the ppd. In it you find reference to what components are used for the driver. I suspect you are missing a filter that the ppd specifies. Or conversely, a different Mac version driver isn't referred to in that linux ppd.

example from one of my Epsons:
*cupsFilter: "application/vnd.cups-raster 100 rastertogutenprint.5.2"
*cupsFilter: "application/vnd.cups-command 33 commandtoepson"

Hope this helps.
 
Comment

kflux

macrumors newbie
Original poster
Jan 18, 2012
2
0
hi gsahli,

i checked if there's a filter missing - and you were right! thanks! so i took the rastertostar binary from the TSP645 (same printer just with cutter instead of tearbar) and put it in the correct folder.

i tried to print again with the same result: just a meter of paper with gazillions of ????? symbols.

weird thing is that the cups error log doesn't show any errors:

Code:
I [29/Jan/2012:01:07:55 +0100] Scheduler shutting down normally.
I [29/Jan/2012:01:07:56 +0100] Saving job cache file "/private/var/spool/cups/cache/job.cache"...
I [29/Jan/2012:12:12:45 +0100] Listening to ::1:631 (IPv6)
I [29/Jan/2012:12:12:45 +0100] Listening to 127.0.0.1:631 (IPv4)
I [29/Jan/2012:12:12:45 +0100] Listening to /private/var/run/cupsd (Domain)
I [29/Jan/2012:12:12:45 +0100] Remote access is disabled.
I [29/Jan/2012:12:12:45 +0100] Loaded configuration file "/private/etc/cups/cupsd.conf"
I [29/Jan/2012:12:12:45 +0100] Using default TempDir of /private/var/spool/cups/tmp...
I [29/Jan/2012:12:12:45 +0100] Configured for up to 100 clients.
I [29/Jan/2012:12:12:45 +0100] Allowing up to 100 client connections per host.
I [29/Jan/2012:12:12:45 +0100] Using policy "default" as the default!
I [29/Jan/2012:12:12:45 +0100] Full reload is required.
I [29/Jan/2012:12:12:45 +0100] Loaded MIME database from '/private/etc/cups': 52 types, 49 filters...
I [29/Jan/2012:12:12:45 +0100] Loading job cache file "/private/var/spool/cups/cache/job.cache"...
I [29/Jan/2012:12:12:46 +0100] Full reload complete.
I [29/Jan/2012:12:12:46 +0100] Cleaning out old temporary files in "/private/var/spool/cups/tmp"...
I [29/Jan/2012:12:12:46 +0100] Listening to ::1:631 on fd 4...
I [29/Jan/2012:12:12:46 +0100] Listening to 127.0.0.1:631 on fd 6...
I [29/Jan/2012:12:12:46 +0100] Listening to /private/var/run/cupsd on fd 7...
I [29/Jan/2012:12:12:47 +0100] Resuming new connection processing...
I [29/Jan/2012:12:35:11 +0100] [Job ???] Request file type is application/pdf.
I [29/Jan/2012:12:35:11 +0100] [Job 188] Adding start banner page "none".
I [29/Jan/2012:12:35:11 +0100] [Job 188] Adding end banner page "none".
I [29/Jan/2012:12:35:11 +0100] [Job 188] File of type application/pdf queued by "flux".
I [29/Jan/2012:12:35:11 +0100] [Job 188] Queued on "TSP600" by "flux".
[B]I [29/Jan/2012:12:35:11 +0100] [Job 188] Started filter /usr/libexec/cups/filter/cgpdftoraster (PID 766)
I [29/Jan/2012:12:35:11 +0100] [Job 188] Started filter /usr/libexec/cups/filter/rastertostar (PID 767)
I [29/Jan/2012:12:35:11 +0100] [Job 188] Started backend /usr/libexec/cups/backend/serial (PID 768)
I [29/Jan/2012:12:35:27 +0100] [Job 188] Completed successfully.
 [/B]
weird huh? i don't know what to try now...

i'd like to get around the option having to buy the USB interface for the printer for 70 bucks...
 
Comment

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.