Starcraft 1 Snow Leopard Firewall issue, how to fix?

Discussion in 'Mac and PC Games' started by Ruahrc, Apr 8, 2011.

  1. Ruahrc macrumors 65816

    Joined:
    Jun 9, 2009
    #1
    My friend and I play SC1 for kicks every now and then. Helps that is a game that runs well on basically any computer, even the MBPs. Usually he comes over and I play it on my PC and he plays on his laptop. In the past, it was all working great- we played LAN games over my network and everything was fine.

    Then he reinstalled his OS (Snow Leopard). Now, we can't get SC1 to work unless he disables the Snow Leopard firewall. I remember we had trouble with this in the past but we found some solution that allowed the firewall to be on but SC still worked. Now, it seems to not work anymore.

    He can boot the game fine and can see games I host on my PC, however, he cannot join them. Only when he disables the firewall does it work.

    Yes, we went in and added the starcraft application to the allowed list of programs in the firewall settings. That should have fixed it, but it doesn't.

    Today I went to his house to play, and installed SC1 in my mac laptop. I experienced the same issue, and the only way I could connect to his game was for me to disable my snow leopard firewall.

    Any ideas for a fix? I would have thought adding the application to the firewall exception list would have worked, but it apparently does not. Stranger is that we used to have it working... until he reinstalled his OS and we could not figure out what the fix was.

    P.S. we are both running the latest version of SC1 (1.161), installed v1.15 via the blizzard downloader then download and applied the latest patch.

    Ruahrc
     
  2. CANEHDN macrumors 6502a

    CANEHDN

    Joined:
    Dec 12, 2005
    Location:
    Eagle Mountain, UT
    #2
    Were you able to add Starcraft to the exception list, in Snow Leopard? Or were you not able to figure it out?
     

Share This Page