Starcraft 10.5.3/10.5.4 fix?

Discussion in 'Mac and PC Games' started by Eluzion, Aug 25, 2008.

  1. Eluzion macrumors 6502

    Joined:
    Aug 7, 2007
    #1
    I was searching around on Google to see if there was a fix out yet and I came across two threads with information regarding this.

    One thread had a posting from a Blizzard staff member saying they were working on a fix for 10.5.3/10.5.4.

    Another thread had a link to the following file:

    http://www.mediafire.com/?3d2hbizmbzt

    Apparently it downgrades your Nvidia video drivers to the version in 10.5.2 and allows you to play Starcraft.

    Has anyone heard of this?
     
  2. Clarkeness macrumors newbie

    Joined:
    Jun 18, 2007
    #2
    Fix OSX 10.5.4 problem

    No but I wish Apple or Blizzard would fix this soon!
     
  3. the Western zoo macrumors 6502

    the Western zoo

    Joined:
    May 16, 2006
    Location:
    Aarhus C, Denmark
    #3
    Yeah, I've read about it and done it, it works... With no problems so far, I have kept the installer as it is also an uninstaller...
     
  4. Eluzion thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #4
    Awesome. Just tried it and it works!

    Any idea how to play the game windowed instead of full screen?
     
  5. the Western zoo macrumors 6502

    the Western zoo

    Joined:
    May 16, 2006
    Location:
    Aarhus C, Denmark
    #5
    yup... just press cmd + m once the game has loaded....

    edit:
    that's also the way to get rid of that annoying mouse cursor...
     
  6. elmateo487 macrumors 6502a

    Joined:
    Jun 12, 2008
    #6
    Whoa though i read that everyone was having problems when they moved back to the normal drivers. That they could not boot into OS X normally?

    It is confirmed that Starcraft and Diablo work in 10.5.5, So i think it would just be more intelligent to wait for that.
     
  7. nakamuramori2 macrumors regular

    Joined:
    Aug 14, 2008
    #7
    what is the Nvidia video drivers ? i've never heard of it. but i can still play on Battlenet w/o any problems..
     
  8. imassents macrumors 6502

    Joined:
    Jul 3, 2008
    #8
    While this is correct, it is not needed due to the fact that there have been no reported issues as a result of using the 10.5.2 drivers. There also is no need to uninstall them before updating to 10.5.5 as the installer will copy over the drivers regardless of the currently installed version.

    If you do need to uninstall the drivers, grab the OS X 10.5.4 combo update and install it on top of your current install to return the drivers back to the newest state. You may need to check software update after doing this just to make sure all secuirty updates are included.
     
  9. alkar macrumors regular

    Joined:
    Jan 12, 2008
    #9
    Yes it is. Works perfectly now.

     
  10. topgunn macrumors 65816

    topgunn

    Joined:
    Nov 5, 2004
    Location:
    Texas
    #10
    Just to clarify, you are saying that 10.5.5 fixes the issue and previous workarounds are no longer necessary?
     
  11. Eluzion thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #11
    That is what he's saying. 10.5.5 isn't out yet though, so this work-around will hold me over until then. ;)
     
  12. nnfaris5 macrumors member

    Joined:
    Aug 21, 2008
    #12
    never heard of it. when is SC II coming out ??
     
  13. alkar macrumors regular

    Joined:
    Jan 12, 2008
    #13
    That's what I'm saying.
     
  14. Eluzion thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #14
    Not soon enough! I hear December is the target release date. Not sure if my current MBP will run it though, hehe.
     
  15. kylestarr macrumors newbie

    Joined:
    Sep 15, 2008
    #15
    Just updated to 10.5.5 and it still does not work. It still crashes immediately although the release notes for 10.5.5 do state "includes extensive graphics enhancements"... weird
     
  16. rbarris macrumors 6502

    Joined:
    Oct 28, 2003
    Location:
    Irvine CA
    #16
    Download the StarCraft or BroodWar 1.15.3 patch from macgamefiles.com or the Blizzard support site. It should enable correct operation of the game on any 10.5.x OS.
     

Share This Page