Starcraft 2 lagging on iMac 27" i7

Discussion in 'Mac and PC Games' started by henry124, Apr 9, 2012.

  1. henry124 macrumors newbie

    Joined:
    Apr 9, 2012
    #1
    So ive recently installed Starcraft 2 on my iMac i7 and i am loosing my mind its runs perfectly on ultra graphics and sometimes the problem isnt even really a problem but lately overtime i try to play online i get massive drops in frame rate and lag the game for everyone else in about 10-15 second intervals. Its not my internet either because my brother and all of my friends have macbook pros and can run the game with no problems at all (except maybe some slower frame rate in large battles) the fact that i paid so much for the best hardware i could get in this 2011 imac and yet im the one with the lag is unbelievably frustrating.

    thoughts? :mad:
     
  2. Azeworai macrumors newbie

    Joined:
    Jan 29, 2011
    #2
    First try Capping the frame rate to maybe 60 or lower. IIRC, if uncapped, the frame rate goes really high and is more or less 'wasted effort' on your machine. This way you can keep your ultra graphics but cap the fps so you get performance and eye candy.

    I capped the frame rate on a low end machine and ran it very well on High graphics settings before I upgraded to a mbp.

    Finder --> Account --> Library --> Application Support --> Blizzard --> StarCraft II --> Variables.txt

    Here is a link to frame rates on wikipedia if you're thinking of what number you'd like to tweak the fps to.
    http://en.wikipedia.org/wiki/Frame_rate

    Or tweak some graphic settings(potentially lowering your eye candy) following this:
    http://us.battle.net/sc2/en/forum/topic/224842575
     
  3. labars macrumors member

    Joined:
    Oct 8, 2011
    #3
    Blizzard has done a really poor job optimizing Starcraft II for OSX. If you want to get good consistant fps you'll have to play it in Bootcamp. At least until Blizzard fixes the issues on OSX.
     
  4. jmnikricket macrumors member

    Joined:
    Jun 6, 2008
    #4
    My impression was that this was an optimization issue as well. I have a 27" i5, and while I can play on Ultra during single player, I had to drastically reduce settings on multiplayer to prevent similar "lag spikes." Now honestly, there's so much multitasking during multiplayer that I never cared too much, but I can see how you might be annoyed.

    I haven't played for a couple months, but back when I was researching it, it seemed the only solution was to either bootcamp (very significant improvements over OSX from what I read) or wait for an eventual optimization patch. You should look around on the blizzard forums to see if anything has changed.
     
  5. AHDuke99 macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #5
    Just play it on high settings. It works fine on my MBP 2.3ghz i7. If I bump it up to ultra then it starts lagging pretty badly. I haven't tried it on bootcamp. I'd prefer not to restart every time I want to play it.
     
  6. jedivulcan macrumors 6502

    Joined:
    May 15, 2007
    #6
    I run everything on high on my quad i7 on medium on my dual i5.

    From what I read on Blizzard's user forums, seems there's a lot of optimization issues and the longer you play the game, the more the lag accumulates.
     
  7. henry124 thread starter macrumors newbie

    Joined:
    Apr 9, 2012
    #7
    Re:

    So tested it out after placing the frame rate cap in, seemed better at first but the issue persists, i just got banned from a game because of how laggy my computer was. The graphics are at high instead of ultra and my frame rate rarely seems to go above about 23fps and its jumps between 7-10 for the entirety of almost any game regardless of objects on screen or in play, custom games and mele
     
  8. Azeworai macrumors newbie

    Joined:
    Jan 29, 2011
    #8
    I run my early 2011 mbp at ultra with no lag and can play hours without issue on osx.

    I don't have an iMac but might I suggest to try lowering the resolution? The more pixels your gfx card needs to push, the harder it'll need to work.

    Are you absolutely certain its not a network issue? Are you using wireless or wired?

    To be absolutely certain its not a network issue, have you tried setting the graphics to absolute minimum and see if you still experience the same issue?
     
  9. bungiefan89 macrumors 6502a

    Joined:
    Apr 5, 2011
    #9
    This.

    Dropping the resolution down from 2560X1440 to 1600x900 should significantly increase gaming performance across the board. And setting the graphics to their lowest possible setting is a good idea as well.

    I do feel your pain, OP. I used to be able to play Starcraft 2 on the highest possible settings often with a relatively high and consistent framerate. But then Blizzard issued patch 1.4 and ever since then the game has performed significantly worse than it did before. Subsequent patches have claimed to fix these problems, but any improvements have been marginal at best.

    Hate to say it, but it looks like the only thing we can do is wait for Blizzard's upcoming 1.5 patch to address the issues... or better yet, see them fixed when Heart of the Swarm comes out.

    For now, lower your graphics expectations, fiddle with the settings, and find the combination that gives you the most optimal framerate/gameplay experience.

    Cheers! :D
     
  10. sinanziric macrumors member

    Joined:
    Apr 8, 2012
    #10
    I was playing StarCraft II Extreme details osx 10.7.3 hackintosh, works like a charm...
     

Share This Page