Starcraft 2; Poor Boot Camp performance. Help!

Discussion in 'Mac and PC Games' started by shakzilla, Jul 26, 2012.

  1. shakzilla macrumors newbie

    Joined:
    Jun 25, 2010
    #1
    Hi all,

    I'm bootcamping Windows 7 Professional x64 on a 2009 unibody MBP, with a 9400m.

    Everywhere I've read says that performance should be a lot better in Windows versus OSX, but it seems exactly the same... SC2 sputters on medium. I installed the latest drivers from NVIDIA, and my bootcamp is up to date (3.3).

    Anyone know why this is happening? Any help/input is much appreciated
     
  2. Wardenski macrumors 6502

    Joined:
    Jan 22, 2012
    #2
    The 9400m is not a powerful card, try lowering the settings. Windows will not make much difference in this case.
     
  3. And1ss macrumors 6502a

    And1ss

    Joined:
    Oct 20, 2009
    #3
    Yep, gotta lower those graphic settings in-game.
     
  4. Nightarchaon macrumors 65816

    Nightarchaon

    Joined:
    Sep 1, 2010
    #4
    9400m, your going to get the same performance under windows as you will under mac os, very little, stick with low settings, no shaders or effects.

    I know the 8600m in my now aging MBP runs starcraft 2 as well under Lion (and now mountain lion) on medium as well as it does under win 7 in bootcamp,but the 8600m seemingly has way more ooomph than the 9400m for some reason, there is maybe, just maybe, 2fps difference between OSes in it since the last patches.
     
  5. shakzilla thread starter macrumors newbie

    Joined:
    Jun 25, 2010
    #5
    Thanks for the responses guys. I guess I'll just stick to the native Mac client, then. I heard the 1.5 beta is supposed to make it perform a lot better, does anyone have any experience with it? Thanks again
     
  6. Aldaris macrumors 65816

    Aldaris

    Joined:
    Sep 7, 2004
    Location:
    Salt Lake
    #6
    Yeah the 1.5 patch is significant in performance! Brings great hope for the expansions to come.
     
  7. AHDuke99 macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #7
    I haven't noticed much of a change with the new patch in terms of performance but maybe it is better. I play on low settings anyway do I won't run into any problems.
     

Share This Page