StarCraft II - Play On Multiple Accounts?

Discussion in 'Mac and PC Games' started by DeepIn2U, May 14, 2010.

  1. DeepIn2U macrumors 603

    DeepIn2U

    Joined:
    May 30, 2002
    Location:
    Toronto, Ontario, Canada
    #1
    I just installed SCII on 10.6.3 OS X.

    On the Mac Mini I'll only be using one account; yet I wish to be able to play it on my Admin account, and have my son play it on his standard account.
    Unfortunately the permissions for the folder StarCraft II which contains the game does not allow my son to even go into it and launch the game (within it)?

    permissions are set to Admin RW, and Everyone Read; this is the same looking at it from my logon and his as well.

    I installed it using my admin account. Updates installed running natively in OS X - yes its in Beta still.

    Any way to fix this or is this the nature of the beta?

    Thanks.
     
  2. aki macrumors 6502a

    Joined:
    Mar 2, 2004
    Location:
    Japan
    #2
    wow hmmm that issue hadn't occurred to me, iiiinteresting...

    Erm, is installing it twice a solution? Ie. installing it under your admin account and installing it under his std account?

    Although I run multiple accounts on my machine every time I've tried to get things working across accounts I've ended up getting a headache - there always seems to be something that doesn't work for some reason or another. Sympathies. But I will probably want to be doing this as well so will monitor thread with interest!
     
  3. kred321 macrumors newbie

    Joined:
    May 3, 2009
    #3
    I can't speak about SC2 specifically but I had the same issue with Diablo 2. Apparently battle.net v1 needed read/write access to the folder in apps and I'm guessing battle.net v2 needs it as well.

    One solution for D2 was to copy entire "Starcraft II" folder onto your son's desktop screen and he can run it from there. You'll have to patch twice though. A likely one patch solution is to give your son's account read/write access to the SC2 folder. (I dunno if there's any potential issues/exploits with granting write access to a folder within "Applications") You probably don't even need to give write access to the entire folder, just a few specific files within, but I never quite figured that out.
     
  4. NGL macrumors member

    Joined:
    Feb 28, 2010
    #4
    Looks like you'll need to set Read / Write for Everyone on the folder, or at least the application file.

    -Nick
     
  5. DeepIn2U thread starter macrumors 603

    DeepIn2U

    Joined:
    May 30, 2002
    Location:
    Toronto, Ontario, Canada
    #5
    I tried that route, granting write permissions to my son's logon from his account (him logged on) and also logged in with myself (admin); neither worked.

    Currently these are the settings for "StarCraft II Beta" folder:
    Sharing & Permissions:
    Blade (Me) - Read & Write
    admin - Read only
    everyone - Read & Write


    btw, the lock pad is locked. not sure what else to do? Maybe its the nature of the BETA?
     

Share This Page