StarCraft & Leopard firewall

Discussion in 'Mac and PC Games' started by m1ss1ontomars, Jan 23, 2008.

  1. m1ss1ontomars macrumors 6502

    Oct 1, 2006
    Leopard's firewall apparently modifies applications when you tell it to "allow" network connections. For example, in StarCraft, when you first try to log on to after an update (for me, I just updated to 1.15.2, the no-cd version), StarCraft will complain that port 6112 is not open (which it should not be), but you can still log on to and chat but not play games.

    Mac OS X will then ask you if you want to deny or allow network connections. If you click allow, it will append data to "Starcraft (Carbon)" starting at offset 155fe9, causing Starcraft to fail all further login checks for checks your application to prevent cheating; the first time you are still able to log in because you're already in by the time the data is appended. After that, Starcraft is 1.7 MB rather than 1.6 MB (actually only 8 KB have been added I think), so your application version can no longer be properly identified.

    Basically, Leopard's firewall is corrupting at least Starcraft, which is one of the worst possible apps to corrupt, due to Blizzard's anti-cheating mechanisms. I think the appended data just allows Mac OS X to recognize it as an allowed app.

    Honestly, Apple, this had better be fixed in 10.5.2 or I'm going to be pissed at this supposedly "improved" firewall. Because it's not improved; it seriously sucks some major ass.
  2. m1ss1ontomars thread starter macrumors 6502

    Oct 1, 2006
    OK, so I was right, as listed here.

    This surreptitious signing needs to stop, as it is neither surreptitious nor beneficial. The signing is supposed to reveal modifications to the programs, but instead cause them to be modified themselves. There are other ways to ensure programs haven't been modified since I allowed them to connect to the internet, ways which don't modify the program itself.
  3. m1ss1ontomars thread starter macrumors 6502

    Oct 1, 2006
    Bump. Doesn't anyone else find this at least a minor problem?
  4. theLimit macrumors 6502a


    Jan 30, 2007
    up tha holler, acrost tha crick
    The Leopard firewall was supposedly changed to not modify programs anymore. It also used to kill Skype and World of Warcraft, which works now.
  5. Flyinfart macrumors newbie

    Mar 16, 2009
    I currently have version 10.5.6 and it started acting up about a week ago. It worked just fine but seemingly randomly stopped letting me join/host games over (hamachi included). Nothing new has been added to the computer, no updates, no new installs, it just stopped working. Exact same problem it sounds like though. I'm going to try some general troubleshooting and get back to this thread, hopefully something will work.
    Since the problem, I've already enabled the port and given the game full access to any port and connection it wants to make (honestly, sounds like a bad idea to me but I trust Blizzard enough...).
    Tried a reinstallation as well, but hasn't worked. Shame. Either our ISPs are the problem, or Starcraft just just decided to simultaneously hate a handful of Mac users. Blame the machine spirit.
  6. Miharu macrumors 6502


    Aug 12, 2007
    I've been using the Leopard firewall for some time now, but it's pretty annoying. It asks every single time if I wish to allow a program to accept network transmissions when I launch them, even if I put each application manually into the list of allowed applications. Is this supposed to be normal?
  7. imassents macrumors 6502

    Jul 3, 2008
    Yes that is normal behaviour for it, one reason why I turned it off.

Share This Page