Starcraft - OS X 5.4

Discussion in 'Mac and PC Games' started by Cymbal, Aug 18, 2008.

  1. Cymbal macrumors newbie

    Joined:
    Jun 3, 2008
    #1
    I don't have a Mac running Leopard yet, but will very soon and I was wondering if Apple/Blizzard fixed the problem with Starcraft running on the new versions of Leopard?
     
  2. Mindflux macrumors 68000

    Mindflux

    Joined:
    Oct 20, 2007
    Location:
    Austin
  3. Xavier macrumors 68020

    Joined:
    Mar 23, 2006
    Location:
    Columbus
    #3
    Seconded
     
  4. jv17 macrumors member

    Joined:
    Aug 7, 2008
  5. elmateo487 macrumors 6502a

    Joined:
    Jun 12, 2008
    #5
    WAIT. What!?

    No it doesn't! I thought that because it is a 256 color app, it wont run on the cards because they do not support them.

    I have been holding off on getting it until it is fixed, so i sure hope that it does work on 10.5.4

    I tried installing it a month ago, and everyone was having the problem that when started it just instantly kicks of the program.
     
  6. Cuyahoga macrumors member

    Cuyahoga

    Joined:
    Jun 12, 2007
    #6
    Still having the same problem. It's really the ONLY game I want to play. :mad:

    To clarify, I have a Mac Pro. I thought the problem was specific to Penryn Macs.
     
  7. imassents macrumors 6502

    Joined:
    Jul 3, 2008
    #7
    Apple and Blizzard both have not released a fix for intel and nVidia based GPU Macs. ATi Macs will have no issues.

    There are work arounds by installing the older drivers from a graphics update in 10.5.2 (that was updated and broken in 10.5.3). You can read about it here:

    Macbook Pros/Mac Pros (and other Macs based on nVidia GPUs)
    http://www.battle.net/forums/thread.aspx?fn=support&t=548720&tmp=1#post548720

    Macbooks (or other Macs based on intel GMA X3100 GPUs)
    http://www.battle.net/forums/thread.aspx?fn=support&t=549029&tmp=1#post549029

    There have been no reports (across about 5 forums) of this fix causing troubles. Please note an uninstall should not be required come 10.5.5 as the updates will overwrite the drivers regardless of their version. If for some reason you wish to uninstall the drivers, you can simply re-run the 10.5.4 combo update linked below
    http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx1054comboupdate.html
    (You may require the security update once more - check software update in the Apple menu to confirm)
     

Share This Page