Starcraft widescreen - disable image stretching?

Discussion in 'Mac and PC Games' started by Bimmi, Sep 14, 2009.

  1. Bimmi macrumors regular

    Joined:
    Jul 22, 2002
    #1
    I recently upgraded (and I use the term loosely) to a Viewsonic VX2433wm widescreen monitor. Both Starcraft and Warcraft III display on it as full, stretched-out screens, with no black sidebars to keep things to the proper aspect ratio. Not only does this look like hell, but it makes the game difficult or even impossible to play sometimes.

    I've been utterly unsuccessful at tracking down a fix for this problem on my own. Any suggestions?

    (running latest versions of both the game and 10.5 Leopard here - video card is a Radeon 9600)
     
  2. imassents macrumors 6502

    Joined:
    Jul 3, 2008
    #2
    Are you connecting the display via it's VGA port (3x5 rows of pins) or the DVI port (it's the larger one)?

    To show the difference
    [​IMG]
    The top one is a VGA plug, and the bottom one is DVI (although it may be a different gender depending which end you look at).

    I can however tell you know that Warcraft cannot be played in 4:3 with black bars. I've been requesting Blizzard fix this for some time now.

    Starcraft (and Diablo) on the other hand can be played in 4:3 with black bars. By default Starcraft and Diablo utilise the non-stretched display modes. The problem here is that some monitors may override this and stretch it by themselves, which is what yours will be doing. Check in the monitors on screen menus for an option to disable the stretching feature. This feature is of course dependant on the first question I asked about DVI/VGA.
     
  3. crazzyeddie macrumors 68030

    crazzyeddie

    Joined:
    Dec 7, 2002
    Location:
    Florida, USA
    #3
    Warcraft III should never stretch your image if you have it setup correctly. It supports almost all widescreen resolutoins, so you should tell it to use the native resolution of your LCD.

    Starcraft will only run at its built-in resolution, which is 4:3, so as imassents said, make sure your LCD isn't set to "force" 16:9 stretched.
     
  4. imassents macrumors 6502

    Joined:
    Jul 3, 2008
    #4
    Warcraft is a 4:3 game. Setting the resolution in game to a widescreen resolution stretches the image. It was done this way so that widescreen users did not have an advantage over 4:3 players - they both see the same on screen and it is distorted to make it fit.

    Due to the way Blizzard has coded it, it is impossible to play Warcraft keeping the 4:3 aspect ratio in tact on a widescreen display.
     
  5. Bimmi thread starter macrumors regular

    Joined:
    Jul 22, 2002
    #5
    The monitor connection is DVI. Would swapping it make any difference here?

    And with all of Blizzard's great Mac support over the years, why the heck can't they code a widescreen fix into their older games? Is it really that hard to add two black bars?
     
  6. haiggy macrumors 65816

    Joined:
    Aug 20, 2003
    Location:
    Ontario, Canada
    #6
    I got used to it. Play with it for awhile and it actually looks fine/better.
     
  7. imassents macrumors 6502

    Joined:
    Jul 3, 2008
    #7
    DVI is the better choice as the screen is less blurry. With VGA it may be possible to adjust the horizontal size of the image to imitate black bars. This will involve a bit of guess work and is generally not worth the trouble.

    They can, it's just they haven't. Starcraft and Diablo support 4:3 with black bars, Warcraft only uses the non-stretched resolutions listed in the Display control panel.

    If you like, post a thread in the battle.net tech support forum asking why you can't do it. Hopefully Lucytr (a Blizzard rep with knowledge of Macs) will find it and possibly pass it along to the correct department.
    http://forums.battle.net/board.html?forumId=12014
    Be sure to label your thread with a [Mac] tag so it stands out. As this is battle.net's support forum, be careful to word your post as though you are asking for help, otherwise you will be referred to the suggestions forum (commonly know as the suggestions graveyard to many players due to it's apparent inactiveness).
     
  8. Sdashiki macrumors 68040

    Sdashiki

    Joined:
    Aug 11, 2005
    Location:
    Behind the lens
    #8
    Cant and wont do it for their older games for the simple fact its coded that way.

    Especially when adding widescreen abilities would give an unfair advantage to Bnet players who can see more real estate at once.

    If you ever played online, itd make sense. (though visually, you get "used to it")
     
  9. Zortrium macrumors 6502

    Joined:
    Jun 23, 2003
    #9
    It was my understanding that actual widescreen support was added specifically for the Mac version of WC3. I'd swear that the screen looked stretched when I played in Windows but didn't when I played in Mac OS X on the same machine.
     
  10. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #10
    It is stretched on every widescreen monitor I've ever seen it run on. I don't think there's a way to fix it on OS X but on Windows you can if you use that Nvidia control panel app. I forget where the setting is but you can make it so it just adds black bars on the sides.
     

Share This Page