Mac Starting with SQL

druid

macrumors newbie
Original poster
Aug 16, 2006
3
0
Hi

I have just installed mySQL on my mac. It seems to have been installed, although when i try to start the database nothing seems to happen

Code:
andrew-roberts-powerbook-g4-15:~ Drew$ sudo /Library/StartupItems/MySQLCOM/MySQLCOM start

Password:
Starting MySQL database server
andrew-roberts-powerbook-g4-15:~ Drew$
Im guessing ive missed something, and im guessing its obvious. I have tried the docs on the website, but none seemed to answer this problem

Can anyone shed some light? Much appreciated
 

MrFrankly

macrumors regular
Jan 11, 2006
110
0
what do you expect to see?

You started the server which just serves but doesn't offer an interface.

If you want an interface to enter SQL queries you have to get a client that can connect to the server you just started. MySQL comes with a client called 'mysql' in which you can type SQL queries. Try typing 'mysql' on the command prompt. If that doesn't work you have to locate the binary and start it from there.
 

druid

macrumors newbie
Original poster
Aug 16, 2006
3
0
Cheers!

I was expecting some form of confirmation but obviously not. I tried typing in 'mysql' at first, but got

Code:
-bash: mysql: command not found
Im guessing I should
locate the binary
but what does that mean?



Many thanks
 

robbieduncan

Moderator emeritus
Jul 24, 2002
25,239
504
Harrogate
mysql appears to be the mysql monitor program. On my install this is in /usr/local/mysql/bin. If you want this command to be available without typing all that you need to add it to your PATH environment variable. Do a search, this has been covered more than one.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.