Startup Disk cannot mount! Help!

Discussion in 'MacBook' started by SingaporeStu, Sep 19, 2010.

  1. SingaporeStu macrumors regular

    Joined:
    Mar 12, 2009
    #1
    Hi Guys,

    I have a problem. I was surfing this site a couple of days ago when my MacBook suddenly froze up. I couldn't Force-Quit anything or do a soft restart, so I decided to just power-cycle restart (pressing the power button until it shut down, then pressing it again to start up). When I did so, my startup disk wouldn't mount.

    I should give you a little background: Mine is a MacBook White early 2009, with upgraded 4GB RAM & 500GB 5400rpm Fujitsu HDD. I took the HDD from an off-the-shelf 2.5" external HDD. It has served me well for slightly over a year, and is only now giving me this problem.

    I have since replaced the original HDD (which I was keeping as a emergency backup, phew) and put the problem HDD in an external FW enclosure.

    I have run Disk Utility on it to try & rectify the problem. Disk First Aid says the disk is fine, but I just couldn't get it to mount. I thought I'd try to erase it and restore from my TM backup, but after I erased the disk, it still couldn't mount. What's worse, now the disk is apparently not writeable, and I can't even erase it. Disk First Aid is still telling me the disk is fine.

    I've also tried booting from my SL install disk, but it won't mount the disk to install SL. It is still visible in Disk Utility, but greyed out.

    Can anyone advise what I can do to recover the disk?

    I can't really bring it in for a warranty exchange, cos I ripped this disk out of the original enclosure, so the enclosure is now completely busted, and obviously the warranty won't be honored. (Buying the external was cheaper than buying just the internal, and Fujitsu had a pretty OK reputation for their harddisks at that point. Could you blame me?)

    So any software or hardware (or combination) solution would be great. Worst case scenario is to get a new HDD, but I'd still like to recover the use of this disk somehow.
     
  2. SingaporeStu thread starter macrumors regular

    Joined:
    Mar 12, 2009
    #2
    Guys, any help would really be appreciated...
     
  3. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #3
    Sounds like the hard disk is toast....

    I don't understand how Disk Utility says the disk is fine but then you say that it wont mount.....

    If it wont mount then Disk Utility cannot check it.

    I suspect you are going to have to buy a new disk - you seem to have erased it and have a Time Machine backup.

    Have you tried the usual things - DiskWarrior and Drive Genius ?
     
  4. rien333 macrumors regular

    Joined:
    Jun 29, 2010
    Location:
    The Netherlands
    #4
    You could try this page: http://support.apple.com/kb/ts1417
    I recommend looking around on the other pages before you give up.
    It did work for me.
    If you have more questions regarding those pages, feel free to ask. :)
     
  5. SingaporeStu thread starter macrumors regular

    Joined:
    Mar 12, 2009
    #5
    Thanks for the suggestions, guys.

    Disk Utility does see it, and can perform a "Verify Disk" on it. But it just can mount it, using the "Mount" function, and it won't mount on the desktop, obviously.

    Disk Utility also tells me that the disk is read-only when I do a Get Info. WTF? I never did anything to make it so. Not on purpose anyway.

    I am thinking of using DiskWarrior, but the price is prohibitive. It is cheaper for me to get a new harddisk than pay for the software. That's probably what I'll do once my pay comes in tomorrow. Then restore from my TM backup, all 300+GB... That'll take all night.

    I'm thinking maybe I'll get Techtools Pro after that. It seems to have a larger variety of functions compared to DiskWarrior, which seems very specialized in diagnosing & fixing logical harddisk problems, but only harddisk problems.

    But thanks anyway for the suggestions.
     
  6. paulypants macrumors 6502a

    paulypants

    Joined:
    Jun 17, 2003
    Location:
    Buffalo, NY
    #6
    If the issue is with the drive physically, than no software tool will help you. I'd try putting in another drive to make sure that mounts ok first if you haven't already. If that is successful, than you know it's not anything else in the MacBook that is the issue (HDD Cable, Logic Board HDD Controller).

    Sounds to me like the drive is physically toast for some reason...I'd buy a new drive instead of buying software...unless you are attempting to recover files.
     
  7. SingaporeStu thread starter macrumors regular

    Joined:
    Mar 12, 2009
    #7
    An update,if anyone's interested.

    I bought a 500GB WD Scorpio Black 7200rpm 2.5" HDD. I must say its heavier than my Fujitsu 500GB 5400rpm HDD...

    Anyways, I restored the image from Time Machine from a point slightly before the fatal crash, and ran a Verify Disk in Disk Utility. It seems there were some problems, so I got them fixed.

    I have yet to startup with my new disk (cos I had to go to work). I'll let you know what happens when I do. I'm also gonna see if I can't recover my Fujitsu.
     

Share This Page