Startup disk full OSX Server Mac mini 2015

Discussion in 'Mac OS X Server, Xserve, and Networking' started by tinius, Mar 9, 2015.

  1. tinius macrumors newbie

    Joined:
    Aug 17, 2009
    Location:
    Norway
    #1
    Tried to find similar posts but no one describes my problem fully, so...

    Brand new Mac Mini 2015 running Yosemite OS X Server.
    256GB Flash disk

    It is running as a file server only and there are practically no apps installed.

    All files stored on LaCie Thunderbolt2 disk array

    Home folders:
    - nothing in the usually large folders (pictures, music, videos/movies etc)
    - no emails
    - no nothing, really

    3 users accounts - with empty home directories

    OS X server gives message "Startup disk full"

    Tried a couple of graphical disk space usage apps and the amount of files shown does not even come close to 100GB.
    Have searched the disk for files to delete but can't find any...

    How do I solve this problem?
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    I'd bet on a runaway log file, probably in /var/log. Be careful that typically a standard admin account will not accurately report other users' home folder sizes due to the lack of read permissions. If your users are only sharing files, you can set up the accounts as sharing only and then they will not have home folders created.
    If you type
    Code:
    sudo du -sh /yourpathhere
    in terminal you'll be able to find folder sizes.
     
  3. tinius thread starter macrumors newbie

    Joined:
    Aug 17, 2009
    Location:
    Norway
  4. tinius thread starter macrumors newbie

    Joined:
    Aug 17, 2009
    Location:
    Norway
    #4
    A follow up on this thread...

    Gave up on OS X yosemite server and did a clean install of yosemite.
    Worked fine for a few months but now startup disk is full again. SSD is 250GB.
    SSD usage is as follows:
    - mac mini still just function as a file server
    - 7,8GB of apps
    - 4,63GB Library
    - 7,38GB System
    - 16,67GB User

    Found a iMovie library on 19GB and deleted that.
    Did a "Get info" on macminiHD and had 19GB free space. Hurray.
    Then... the available free space steadily decreased as if there were a file that getting bigger by the second..
    Lost 1,5GB of free space in about 5 minutes now...

    crashreport and secinitd processes are constantly going at full throttle. Force quitting them does not help. There seems to be an app that causes constant crash reports.

    What does this secinitd process?

    Never experienced this on my other macs. Any ideas anyone?
     
  5. tinius thread starter macrumors newbie

    Joined:
    Aug 17, 2009
    Location:
    Norway
    #5
    update 2

    Deleted iMovie altogether and then crashreport process vanished. iMovie was used once a few weeks ago and not opened since.

    Now I have to find the hidden files iMovie probably created. Any clues how to find them? How can I find the big files?
     
  6. gallico916 macrumors newbie

    gallico916

    Joined:
    Jun 27, 2014
    Location:
    Austin, TX
    #6
    Hey tinius,

    Look also for the local time machine backup files, I know they grow up quite a bit in size.
    You can disable the local time machine via the command line:

    sudo tmutil disablelocal
     
  7. mac8867 macrumors 6502

    Joined:
    Apr 5, 2010
    Location:
    Saint Augustine, FL
    #7
    Second time posting this link today, very strange. I have no affiliation with this source forge project, but I love the tool. It graphically shows you exactly what is taking all of the space on a drive

    http://grandperspectiv.sourceforge.net/
     
  8. tinius, Oct 3, 2015
    Last edited: Oct 3, 2015

    tinius thread starter macrumors newbie

    Joined:
    Aug 17, 2009
    Location:
    Norway
    #8
    Hi again, guys!

    I tend to believe this is a Mac Mini issue.

    After a giving up on Yosemite Server I performed a clean install of Yosemite. Everything worked swimmingly.
    GoodSync pretty much the only app installed on this MacMini.

    After upgrading to El Cap I suddenly ended up with a full startup disk.

    Usage of the 250GB SSD hard drive is as follows:
    System 7,59GB
    Library: 5,31GB
    Users: 5,89GB
    Applications: 1,54GB

    There are no files stored on the Mac Mini itself. All files are stored on a LaCie 2Big 8TB Thunderbolt2 disk.
    GoodSync and iStatmenu being the only apps installed.

    TimeMachine not enabled, so no local snapshots or anything.

    The Mac Mini is just a fileserver, controlled with Apple Remote Desktop.

    This starts to annoy me. Any good advise?
     
  9. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #9
    Is file sharing the ONLY service enabled? If so, I still think it's a runaway log file. You likely have some process crashing over and over. What's showing in the system log in Console?
    This isn't a problem specific to Mac minis running as servers.
    As I suggested back in March, what is the output of the following code in Terminal:
    Code:
    sudo du -sh /
     

Share This Page