Startup Problems

Discussion in 'MacBook Pro' started by devii, Apr 21, 2010.

  1. devii macrumors newbie

    Joined:
    Apr 21, 2010
    #1
    I feel bad about my very first post being about a technical issue, but I really need help. ):

    So, earlier today my five months old, 13'' MacBook Pro was starting to give me slow responses, so I decided to reboot. After ten minutes in the "white screen with Apple logo and the rotating gear", I force powered it off. When I turned it on, I found it to be, again, stuck on the same screen.

    Now, about four hours later, I've tried everything I have found in the internet to no avail. When I try to go with the safe mode, the progress bar disappears halfway and it never boots. I tried resetting the PRAM too, and nothing changed. However, Single User mode runs all and well, and the "/sbin/fsck -fy" even says my HD is fine. But when I try to boot with the safe mode where I can see the boot progress, it stops when multiple "disk0s2: I/O error" lines start to appear.

    After some more research, I decided to reinstall Snow Leopard, but it won't boot from the DVD, even if I press C.

    Is there any solution besides throwing it on the floor? I'm almost considering it...
     
  2. guydude193 macrumors 6502a

    Joined:
    May 15, 2009
    Location:
    MI
    #2
    If you throw it on the floor, you'll void your AppleCare warranty.
    That's weird if you can't boot off the disk. You might want to put the reinstall disc in, and then hold 'D' down while it boots up. It'll run a hardware test. If you can't run off that, either, I'd take it in to Apple because that would mean you'd have a SuperDrive problem.
     
  3. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #3
    Sounds like a dead/dying hard drive to me, I'm typing on a non-unibody MBP right now which is having similar issues, I'm installing a WD Scorpio Black 320gb hard drive in there tomorrow, hopefully that'll solve it.
     

Share This Page