Sticky Forced Subtitles

Discussion in 'Apple TV and Home Theater' started by Ka Ora!, Feb 16, 2014.

  1. Ka Ora! macrumors regular

    Joined:
    Jan 23, 2009
    #1
    I have an issue with newer films and the way the forced subtitles are encoded if any forced subtitle come up during the film they stick there until another subtitle changes them and the only way to get rid of them is quit the film and resume the film. Films that are over two years old this doesn't happen on so at some point Apple changed the way forced subtitles were encoded into the films although it could be further down the chain I don't know how much interaction Apple has in preparing the films etc. Admittedly I have a 1st gen Apple TV but removing the hard drive I felt was a step backwards so I have never upgraded.
     
  2. mcnallym macrumors 6502a

    Joined:
    Oct 28, 2008
    #2
    I had this issue as well with the Mk1 AppleTV.
    Also had the issue whereby would get a black rectangle about where would get subtitles up.

    If quit and then resume would playback fine as you found with the forced subtitles.

    I raised a care with Apple who whilst the TAC guy basically admitted yes, it appears to be an encoding issue and raised it with the software developers then I haven't heard anything back since. He did warn me however that no guarantee that they would do anything regarding this.

    I have since purchased a Mk3 and all my issues have disappeared.

    I went through rebuilding my mini, creating a separate iTunes library, redownloading files, factory resetting my Apple TV, tweaking various settings, and borrowed a friends mk3 to show was only on the AppleTV Mk1 that had the issue, and that the Mk1 isn't faulty.

    Apple have definitely changed something in there code for the ATV regarding subtitling however they don't seem to be doing anything and they still claim the Mk1 can playback iTunes content.
     
  3. Ka Ora! thread starter macrumors regular

    Joined:
    Jan 23, 2009
    #3
    I suspect the ticket got filed in the bin why resolve an issue if the fault can generate a few sales as people upgrade. Im hoping that the aTV 4 will bring back the hard drive which seems reasonable if it does support apps although they may somehow opt for a SSD for apps and continue to stream films which keep the scope for 16 32 and 64 Gb models like other iOS devices. Im just trying to work out what the most cost effective standalone iTunes server/nas would be I would then upgrade the atv's in the house.
     
  4. rayward macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #4
    I had the same problem with my old Mk1s when using subs added as an srt file. The last subtitle line would hang on the screen for the rest of the movie.

    This went away once Handbrake added the forced sub search and burn in option. Burned in subs performed perfectly. I, too, have since upgraded to Mk3s, and I can't remember whether the HB update came before the ATV upgrade, or vice versa.

    Either way, burning in the subs with HB is both easy, error proof and you get the original format / font too.
     
  5. Ka Ora! thread starter macrumors regular

    Joined:
    Jan 23, 2009
    #5
    My issue is with iTunes purchased content, Although I am looking at setting up some form of nas and will be using handbrake a fair bit so thanks for the tip:)
     
  6. rayward macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #6
    I believe iTunes content uses srt-type subs, so they can be turned on and off. Burned in subs are, by their very nature, a permanent part of the screen image. That may explain why you experienced the issue with iTunes content.

    On the topic of a NAS, I used to have one for my iTunes library, but switched to using an external HDD attached to my iMac via Firewire. The problem I had with the NAS was two-fold:

    1) This doubles up the data volume on your network as your iTunes host draws down the content from your NAS, and then puts it back on the network to send it to the target player; and

    2) If the iMac rebooted - after a power outage, for example - iTunes would often open prior to the NAS mounting on the network. When this happened, iTunes would default back to the local (empty) folder, and I had to go in and redirect it to the NAS.

    Neither of these are fatal issues, but I got fed up with messing with it. Putting my library on the directly connected HDD solved all of the above.
     
  7. westrock2000 macrumors 6502

    Joined:
    Oct 18, 2013
    #7
    I also have Handbrake burn in forced.

    I have only had one observed issue like this with Handbrake. It was on the Bluray of James Cameron's Avatar. There was one section where "Naavi" text stayed on the screen until the next forced subtitle showed up, and then it worked again from there on out.

    But this was also around the time Handbrake was just starting to support Bluray discs and I was using a nightly version. So I just need to re-rip it and I'm sure it will be fine.
     
  8. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #8
    If you were using MakeMKV to rip, I think the source of the problem were how flags were being set by MakeMKV. I know HB and MakeMKV were pointing fingers at each other about the true source of the issue but I think it finally ended up being a MakeMKV issue. Which has been fixed.
     
  9. d.steve macrumors regular

    Joined:
    Jan 6, 2012
    #9
    A good test might be to see if the same problem happens when you play it on a Mac or PC (or even an IOS device). That would help verify that it is in fact specific to your ATV v1 or not.
     

Share This Page